Problem solved? Update - Saturn ION RedLine Forums
Saturn ION Redline Saturn ION Redline Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Saturn ION RedLine Forums > ION Redline Forums > ION Redline Discussion

RedlineForums.com is the premier Saturn Ion Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 12-03-2012, 09:46 PM   #1 (permalink)
Member
 
cblackredline's Avatar
 
Join Date: Feb 2012
Location: indiana
Posts: 51
Problem solved? Update

So a few months ago I tried to get some help on here on what could be wrong with my rl and got a few good suggestions but when we finally figured it out it was too late. Long story short it ended up melting a piston. 6000 dollars later I'm hoping it will all be good lol

What I was told by some experts in the rl world was that the previous owner (not going to mention who because they're on here) had put or had someone put a horrible tune on the car. Ever since I bought it, it would get waaayyy to much gas because it wasn't tuned to the 80lb injectors like it should have been. I got it tuned but it was too late the damage had already been done. It was a ticking time bomb.

Now I'm hoping it will all be good considering all the money I've put in it. Girdled block, valve springs and seals, head studs, harmonic balancer, new clutch, pistons rods and pretty much everything else to build it up. I don't need the fastest car in the world so I had a pretty mild tune put on it.

Just thought I'd throw an update out there and say thanks for all who tried to help

Sent from my SAMSUNG-SGH-I727 using AutoGuide.Com Free App
cblackredline is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-04-2012, 12:17 AM   #2 (permalink)
Senior Member
 
Join Date: Feb 2007
Posts: 915
Glad you got it running.... Much $ later

Sent from my SPH-L710 using AutoGuide.Com Free App
__________________
'06 Blue IRL
Build Thread
DFWGMElite Member
slitterell is offline   Reply With Quote
Old 12-04-2012, 04:39 AM   #3 (permalink)
Member
 
cblackredline's Avatar
 
Join Date: Feb 2012
Location: indiana
Posts: 51
Yep just trying to work out the kinks now with the new motor

Sent from my SAMSUNG-SGH-I727 using AutoGuide.Com Free App
cblackredline is offline   Reply With Quote
Old 12-04-2012, 08:19 PM   #4 (permalink)
Senior Member
 
Join Date: Oct 2010
Location: St. Cloud, MN
Posts: 3,826
Holy shit that's a pile of money, glad you got it figured out. Indiana huh, that Shroogis's car?
__________________
Mods: ZZP stage 3, 2.9 pulley, prefab pcm, 60lbers, AEM gauges, KandN CAI, SPEC stage 3+, ZZP S3 heat exchanger
ZZP long tube header, Strut bar, ZZP rear mount, Progress rear sway bar, Redline Tuning hood struts freshly installed.
recaro86 is offline   Reply With Quote
Old 12-04-2012, 08:24 PM   #5 (permalink)
Senior Member
 
Droxity's Avatar
 
Join Date: Dec 2010
Location: W Chi burbs
Posts: 2,327
Not Shroogis car...glad to see OP worked it out...bad tunes have killed more of our cars than probably anything else.
__________________
The thought is pure ambiguous
Droxity is offline   Reply With Quote
Old 12-04-2012, 08:30 PM   #6 (permalink)
Senior Member
 
Join Date: Oct 2010
Location: St. Cloud, MN
Posts: 3,826
Bad slave cylinders in your case Drox, that all squared away now?
recaro86 is offline   Reply With Quote
Old 12-04-2012, 09:55 PM   #7 (permalink)
Member
 
cblackredline's Avatar
 
Join Date: Feb 2012
Location: indiana
Posts: 51
Yeah so far its been good other than the axle goin out. They'll be on next Wednesday. Only thing now is it Burns some oil and it makes some noise when its cold but its still not broke in and its got thin ass break in oil. About another thousand miles and it'll be back to full synthetic and we'll see what happens then

Sent from my SAMSUNG-SGH-I727 using AutoGuide.Com Free App
cblackredline is offline   Reply With Quote
Old 12-04-2012, 09:56 PM   #8 (permalink)
Member
 
cblackredline's Avatar
 
Join Date: Feb 2012
Location: indiana
Posts: 51
And no idk who that is but its not from him. It was a southern car that's all I'll say.

Sent from my SAMSUNG-SGH-I727 using AutoGuide.Com Free App
cblackredline is offline   Reply With Quote
Old 12-05-2012, 06:58 AM   #9 (permalink)
Senior Member
 
Droxity's Avatar
 
Join Date: Dec 2010
Location: W Chi burbs
Posts: 2,327
Quote:
Originally Posted by recaro86 View Post
Bad slave cylinders in your case Drox, that all squared away now?
No thread jack but not squared away yet...should be done this week though.
Droxity is offline   Reply With Quote
Old 12-05-2012, 08:13 AM   #10 (permalink)
Senior Member
 
05VUE-Redline-06ION's Avatar
 
Join Date: Aug 2009
Location: Columbus, Ga
Posts: 1,674
well it aint mine...lol...mines still at the machine shop..lol
__________________
My ION for sale $10,500

6.0L LS2 400HP Trailblazer SS Here I come!!!!
05VUE-Redline-06ION is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
AC problem UPDATE PistoNHeaD Problems & Troubleshooting 0 08-25-2008 06:48 PM
WOOT!!! my intercooler pump problems are solved!!! boosthard05 ION Redline Discussion 13 08-23-2008 07:02 PM
Idle Problem/Limp mode Problem jekqmb Problems & Troubleshooting 9 08-17-2007 06:25 AM
My MPG issue might be solved sheek360 Problems & Troubleshooting 21 01-16-2007 11:47 AM
Update on Clutch Problem! zvillepimp1982 Problems & Troubleshooting 9 10-06-2005 10:55 AM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -6. The time now is 07:59 PM.



Search Engine Optimization by vBSEO 3.3.2