Limp Mode Help!!! - Saturn ION RedLine Forums
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 11 (permalink) Old 05-05-2017, 08:25 AM Thread Starter
Junior Member
 
Join Date: May 2017
Posts: 2
Limp Mode Help!!!

i just aquired an 04 Saturn ion redline, i had a basic ion and somewhat familiar with the cars. was told it had a stage 3 kit and i can see the 2.8 pully and it has 60# injectors and new ECU, but i dont see the intercooler so i was concerned for that but my problem is it also has a larger throttle body and when i gas the car too hard it goes into limp mode, id assume the tune isnt set for the TB and its putting more air into the motor than the system is supposed to see so it freaks out, i plan on putting origional TB on but looking for other inputs, codes are showing P1238 and P0532 ive looked up both codes and the only one i see is the Throttle Position sensor causing the limp mode.
can anyone help me out?
ThatOneGuy823 is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 05-05-2017, 11:25 AM
Senior Member
 
1Redline's Avatar
 
Join Date: Nov 2014
Location: NE US
Posts: 1,634
Quote:
Originally Posted by ThatOneGuy823 View Post
i just aquired an 04 Saturn ion redline, i had a basic ion and somewhat familiar with the cars. was told it had a stage 3 kit and i can see the 2.8 pully and it has 60# injectors and new ECU, but i dont see the intercooler so i was concerned for that but my problem is it also has a larger throttle body and when i gas the car too hard it goes into limp mode, id assume the tune isnt set for the TB and its putting more air into the motor than the system is supposed to see so it freaks out, i plan on putting origional TB on but looking for other inputs, codes are showing P1238 and P0532 ive looked up both codes and the only one i see is the Throttle Position sensor causing the limp mode.
can anyone help me out?

why no intercooler? , I would see if all the parts are there for the build you want.

If you want that setup intercooler is very important even for stock
1Redline is offline  
post #3 of 11 (permalink) Old 05-05-2017, 11:00 PM
Senior Member
 
Rebel Redline's Avatar
 
Join Date: Dec 2015
Location: Central Alabama
Posts: 404
Garage
First, junk the LS4, not needed for a supercharged car. Hell, my turbo car is breathing through an LE5 TB that is smaller than the stock LSJ, and my car makes 421 horses...

Second, an auxiliary heat exchanger is not necessary for a 2.8 so long as you have a dual pass and Option B. You need to check for proper intercooler pump function and make sure the stock heat exchanger is there and bled properly.

Your codes are for ( If you had the typo I think you did and actually meant P2138 ) Pedal Position/Throttle Correlation and A/C Pressure Sensor Voltage Low.

Could be part related, could be moisture related. Clean the TB plug with electrical contact cleaner and check your sunroof drains.

2004 Saturn Ion Redline - S256ET | Ported Head
421whp/354wtq @ ~23psi on E30

2000 Z28 -
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
318/304 NA - 435/380 N2O

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
, Gone but not forgotten.

Last edited by Rebel Redline; 05-05-2017 at 11:04 PM.
Rebel Redline is offline  
 
post #4 of 11 (permalink) Old 05-07-2017, 03:11 PM
Senior Member
 
MBRedline's Avatar
 
Join Date: Sep 2010
Location: Southwest Virginia
Posts: 285
Quote:
Originally Posted by Rebel Redline View Post
First, junk the LS4, not needed for a supercharged car. Hell, my turbo car is breathing through an LE5 TB that is smaller than the stock LSJ, and my car makes 421 horses...

Second, an auxiliary heat exchanger is not necessary for a 2.8 so long as you have a dual pass and Option B. You need to check for proper intercooler pump function and make sure the stock heat exchanger is there and bled properly.

Your codes are for ( If you had the typo I think you did and actually meant P2138 ) Pedal Position/Throttle Correlation and A/C Pressure Sensor Voltage Low.

Could be part related, could be moisture related. Clean the TB plug with electrical contact cleaner and check your sunroof drains.
Sunroof drains???
MBRedline is offline  
post #5 of 11 (permalink) Old 05-07-2017, 05:15 PM
Senior Member
 
Rebel Redline's Avatar
 
Join Date: Dec 2015
Location: Central Alabama
Posts: 404
Garage
Quote:
Originally Posted by MBRedline View Post
Sunroof drains???

How-To: Fix sunroof drain leaks
Rebel Redline is offline  
post #6 of 11 (permalink) Old 05-07-2017, 07:03 PM
Senior Member
 
MBRedline's Avatar
 
Join Date: Sep 2010
Location: Southwest Virginia
Posts: 285
Quote:
Originally Posted by Rebel Redline View Post
Quote:
Originally Posted by MBRedline View Post
Sunroof drains???

How-To: Fix sunroof drain leaks
Yeah I know the drains stop up, but I wasn't following what that had to do with the cel code...???????
MBRedline is offline  
post #7 of 11 (permalink) Old 05-07-2017, 08:00 PM
Senior Member
 
Rebel Redline's Avatar
 
Join Date: Dec 2015
Location: Central Alabama
Posts: 404
Garage
Quote:
Originally Posted by MBRedline View Post
Yeah I know the drains stop up, but I wasn't following what that had to do with the cel code...???????
Leaks down into the wiring. It's a pedal/TB Correlation code. Coule be something to at least rule out.
Rebel Redline is offline  
post #8 of 11 (permalink) Old 05-08-2017, 06:24 AM
Senior Member
 
MBRedline's Avatar
 
Join Date: Sep 2010
Location: Southwest Virginia
Posts: 285
Quote:
Originally Posted by Rebel Redline View Post
Quote:
Originally Posted by MBRedline View Post
Yeah I know the drains stop up, but I wasn't following what that had to do with the cel code...???????
Leaks down into the wiring. It's a pedal/TB Correlation code. Coule be something to at least rule out.
Interesting, learned something. ?
MBRedline is offline  
post #9 of 11 (permalink) Old 05-08-2017, 06:43 AM Thread Starter
Junior Member
 
Join Date: May 2017
Posts: 2
well i did notice from what i see is that its a full stage 2 not stage 3 so im running a tuned ECU with 60# injectors, was told it had a throttle body but both throttle bodies i have are the same size but once i put the original on i tried to get it into limp mode and couldn't so i thought i fixed the issue, went to autozone to clear the codes and had to leave before i could do it so once i turned the car on and got into it a little bit boom back into limp mode, so i know its the accelerator switch but was told the pedal and switch were replaced but im going to put the original back in to see if it helps, also should i put electric grease in the sensors to rule out connection issues? again i appreciate all the input i just want to be able to pedal to the floor and not have to worry.
ThatOneGuy823 is offline  
post #10 of 11 (permalink) Old 05-08-2017, 02:03 PM
Senior Member
 
1Redline's Avatar
 
Join Date: Nov 2014
Location: NE US
Posts: 1,634
Quote:
Originally Posted by ThatOneGuy823 View Post
well i did notice from what i see is that its a full stage 2 not stage 3 so im running a tuned ECU with 60# injectors, was told it had a throttle body but both throttle bodies i have are the same size but once i put the original on i tried to get it into limp mode and couldn't so i thought i fixed the issue, went to autozone to clear the codes and had to leave before i could do it so once i turned the car on and got into it a little bit boom back into limp mode, so i know its the accelerator switch but was told the pedal and switch were replaced but im going to put the original back in to see if it helps, also should i put electric grease in the sensors to rule out connection issues? again i appreciate all the input i just want to be able to pedal to the floor and not have to worry.


could be a lot of different things that influence the limp mode

I have an "unmodified" GM stage 2 and when I got mine it was going into limp and hesitating on full throttle

took a while 1.5 - 2 years before I got it back to "specs" - did a lot of maintenance

How long have u own your IRL?
1Redline is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Saturn ION RedLine Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Limp Mode ATripp General Discussion 1 05-19-2014 12:41 AM
Limp mode help BLu3LinE Problems & Troubleshooting 10 10-26-2011 02:49 PM
limp mode? zero2redline Problems & Troubleshooting 5 11-10-2007 11:26 PM
Limp Mode....Why? BKTU1 Problems & Troubleshooting 5 09-08-2006 02:33 PM
limp mode 1quick98_gs ION Redline Discussion 11 04-21-2005 05:38 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome