Bad grinding noise. Half shaft and hanger gone. (Pics) - Saturn ION RedLine Forums
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 27 (permalink) Old 12-05-2008, 02:37 PM Thread Starter
Member
 
Judders's Avatar
 
Join Date: Jul 2007
Location: PEI Canada
Posts: 53
Bad grinding noise. Half shaft and hanger gone. (Pics)

So I have been having this horrible jingle and grind noise in my car, only sometimes though. I got it thrown up on a lift today and they found that the half shaft and hanger were gone. I am not sure of the proper terminology for it. But the bearing and shaft anyways. The bearing dried all out and now there is a ton of movement in the shaft.

What is the proper name for these and what cost am I looking at to replace them? Do I have to replace both the shaft and the housing, or just the bearing and clamp if the shaft has not been damaged. Has anyone else had this problem?

Also what sensor is the one in the pics, I think the shaft might be hitting it, and my ABS light is on.

On top of this my front sway bar links need replacing too. What do you guys reccomend for these. I autocross so something good that will last awhile.






2004 Ion Redline

Last edited by Judders; 12-05-2008 at 02:39 PM.
Judders is offline  
Sponsored Links
Advertisement
 
post #2 of 27 (permalink) Old 12-05-2008, 03:17 PM Thread Starter
Member
 
Judders's Avatar
 
Join Date: Jul 2007
Location: PEI Canada
Posts: 53
So I believe that I have figured out that this is the intermediate shaft, I just cant seem to find one to buy.

2004 Ion Redline
Judders is offline  
post #3 of 27 (permalink) Old 12-05-2008, 03:19 PM
Senior Member
 
NCStateRedline's Avatar
 
Join Date: Oct 2007
Location: Raleigh, NC
Posts: 1,659
The sensor I believe you're referring to is the speed sensor.

I'm not sure what the name of what that part is, but you are talking about what the shaft runs though to the right of that sensor/gear correct?

Blue '04 Redline Best ET Gas:13.87@103.5, E85:13.94 @ 109.17

289 WHP/262 WTQ on E85
K&N CAI, HP Tuned, zzp heat exchanger, 2.8, 80's, zzp header/dp, GMPP clutch, front and rear TTR mounts, Nitto Neogens, Hawk Pads, irotor cross drilled/slotted rotors.
Boost gauge/ladder tach w/o amishland- courtesy Spike50002
NCStateRedline is offline  
post #4 of 27 (permalink) Old 12-05-2008, 06:30 PM
Senior Member
 
qwikredline11's Avatar
 
Join Date: Jan 2008
Location: Ontario Canada
Posts: 4,728
Quote:
Originally Posted by Judders View Post
So I believe that I have figured out that this is the intermediate shaft, I just cant seem to find one to buy.
if you are stuck i have them email qwikredline@hotmail.com
qwikredline11 is offline  
post #5 of 27 (permalink) Old 12-05-2008, 07:30 PM
Senior Member
 
crazybrew609's Avatar
 
Join Date: Jul 2005
Posts: 2,813
thank god you have an 04

you can get the "hanger" and the shaft separately but if your wheel is bad it's looking like you need a new shaft and a new support.. easy to install just pull of the outer axle an then unbolt the support and pull out the intermediate shaft.. you might need to top off the tranny fluid but only slightly

very easy to replace. call saturn no one has an aftermarket one
crazybrew609 is offline  
post #6 of 27 (permalink) Old 12-06-2008, 10:06 AM Thread Starter
Member
 
Judders's Avatar
 
Join Date: Jul 2007
Location: PEI Canada
Posts: 53
Quote:
Originally Posted by crazybrew609 View Post
thank god you have an 04

you can get the "hanger" and the shaft separately but if your wheel is bad it's looking like you need a new shaft and a new support.. easy to install just pull of the outer axle an then unbolt the support and pull out the intermediate shaft.. you might need to top off the tranny fluid but only slightly

very easy to replace. call saturn no one has an aftermarket one
Thanks, and yes the shaft and hanger both need replacing, I actually got the info from your thread, seems you had the problem too haha. My dealership is retarded though and they are trying to get me to take it in cause they cant seem to understand what part it is and are telling me that I must mean an axle.

I will give another try today! Gotta get this replaced before going home for christmas.

2004 Ion Redline
Judders is offline  
post #7 of 27 (permalink) Old 12-06-2008, 10:13 AM Thread Starter
Member
 
Judders's Avatar
 
Join Date: Jul 2007
Location: PEI Canada
Posts: 53
Quote:
Originally Posted by NCStateRedline View Post
The sensor I believe you're referring to is the speed sensor.

I'm not sure what the name of what that part is, but you are talking about what the shaft runs though to the right of that sensor/gear correct?
yes beside the sensor.

If that is the speed sensor it looks like I am going to have to try figure out why that darn ABS light is on still.

2004 Ion Redline
Judders is offline  
post #8 of 27 (permalink) Old 12-06-2008, 10:15 AM
Senior Member
 
Big Knight's Avatar
 
Join Date: Mar 2005
Location: Duanesburg NY
Posts: 2,967
I don't think the speed sensor on your axle should have anything to do with the ABS. Check the sensors at each wheel.

Driving a 2006 Chile Pepper Red Redline with Comp Package and Stage 2, 110K miles.

Red Clan Grand Master Assassin...
Big Knight is offline  
post #9 of 27 (permalink) Old 12-06-2008, 01:05 PM
Senior Member
 
qwikredline11's Avatar
 
Join Date: Jan 2008
Location: Ontario Canada
Posts: 4,728
Quote:
Originally Posted by Big Knight View Post
I don't think the speed sensor on your axle should have anything to do with the ABS. Check the sensors at each wheel.
damn you are good....vss is for pcm only..
qwikredline11 is offline  
post #10 of 27 (permalink) Old 12-06-2008, 04:10 PM
Senior Member
 
crazybrew609's Avatar
 
Join Date: Jul 2005
Posts: 2,813
the speed sensor is part of the abs system... it needs to know the car's speed to know what the wheel speed should be at
crazybrew609 is offline  
Sponsored Links
Advertisement
 
Reply
Gear in this thread - Powered by O'Reilly Auto Parts

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Saturn ION RedLine Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Supercharger....grinding noise? Rky29 Problems & Troubleshooting 7 12-14-2007 02:26 PM
Intermediate/ half shaft failure? Rear-Vue Problems & Troubleshooting 6 12-09-2007 11:57 AM
Half shaft question?? myredline Performance Modifications 6 08-30-2006 01:55 PM
New TSB for half shaft? mailmars General Discussion 4 09-20-2005 06:30 PM
Bad half shaft? 18 LB Bst Dreamer General Discussion 23 09-20-2005 01:49 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome