Coolant Level Sensor - Saturn ION RedLine Forums
Saturn ION Redline Saturn ION Redline Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Saturn ION RedLine Forums > ION Redline Forums > Problems & Troubleshooting

RedlineForums.com is the premier Saturn Ion Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 05-07-2009, 07:27 PM   #1 (permalink)
Senior Member
 
jeepinbanditrider's Avatar
 
Join Date: Oct 2008
Location: NAS JRB Fort Worth
Posts: 651
Coolant Level Sensor

Everytime I start my car I get a "coolant" warning on the info center where the mileage is. The coolant is full at all times I've even added extra and to no avail. It still throws the warning at me everytime I start the car.

Sensor appears to be hooked up and as far as I know is good to go though I guess it could be a faulty sensor. Anyone ever have this problem or know what could be causing it.
__________________


Semper Fi!

"Be polite, be professional, but always have a plan to kill everyone you meet."
jeepinbanditrider is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-13-2009, 04:45 PM   #2 (permalink)
Senior Member
 
korax123's Avatar
 
Join Date: Nov 2004
Location: Arizona City,AZ
Posts: 2,193
Im pretty sure you have to buy a whole new resivior. I don't think the sensor comes out. It's not to fun removing the coolant tank i've done it before it sucks.
__________________
04 Ion Redline
---Mods---
2.8" pulley/42lb Injectors
---------------------------------------------
Best Time - 14.718
Best Trap speed - 100.42mph
---------------------------------------------

korax123 is offline   Reply With Quote
Old 05-13-2009, 08:16 PM   #3 (permalink)
sold my body 4 turbo parts, but im still slow
 
Join Date: Aug 2008
Posts: 10,144
pull the sensor for the coolant that is near the fuel rail you can't miss it. it's sticking up. pull it look it over and put it back in and see if that helps. mine threw that coolant warning today because when i swapped my injectors i guess that i didn't put it back like my baby wanted the sensor to be in
daythecountrydied21 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
LEVEL 5 CV joints from the DSS fullthrottle Performance Modifications 9 01-21-2008 03:41 PM
Question about Intercooler Coolant level... IONredlineRACER Problems & Troubleshooting 4 05-05-2007 11:15 PM
2006 ION level 3 2.4L str8racn General Discussion 34 02-21-2006 06:17 PM
Low Brake Fluid Level my_bd ION Redline Discussion 6 10-13-2005 04:42 PM
oil level question louballs ION Redline Discussion 65 10-11-2005 08:23 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -6. The time now is 03:14 PM.



Search Engine Optimization by vBSEO 3.3.2