no acceleration!? - Saturn ION RedLine Forums
 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 10-24-2013, 10:25 AM Thread Starter
Junior Member
 
Join Date: Oct 2013
Posts: 2
need help! no accelaration

I just recently got an 04 Saturn Ion Redline with the 2.0L 4 Cyl with 107,000 miles. I was driving home the other day and punched it at a light, and all of a sudden I lost all acceleration. The car was running good and my boost gage was saying the vacuum was fine but I had no boost, the clutch feels normal and it shift just fine. I could smell a faint burnt plastic smell. so I drove it up to the nearest auto parts store and ran the code, p1182, which is the performance supercharger sensor. The other day I had a code read and I remember it was for the TPS, but it is not pulling this code anymore. It will still drive, but it still doesn't have any acceleration and there is a very slight vibration in neutral, but not in any other gears. I am going to clean the TB, MAF, and Air filter today and This weekend I am going to change the trans fluid.. any other ideas on what could be wrong. I didn't have any problems with the clutch or tranny before this no slipping or grinding.

Last edited by jake.bowden; 10-24-2013 at 12:22 PM.
jake.bowden is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 10-24-2013, 12:29 PM
Senior Member
 
Join Date: Feb 2007
Posts: 1,014
well, I would say congratulations but it looks like you were had.

It wouldn't be the Transmission or clutch. Clean your Maf, throttle body, and make sure you air filter is new. Also, make sure your vacuum lines are in tact.

'06 Blue IRL
Build Thread
DFWGMElite Member
slitterell is offline  
post #3 of 10 (permalink) Old 10-24-2013, 03:10 PM
Senior Member
 
golden chicken's Avatar
 
Join Date: Feb 2007
Location: Acton, MA
Posts: 9,398
Sounds to me like the clutch quit.



Q: What's the difference between a bolt and a screw?
A: First, you screw. Then, you bolt.
golden chicken is offline  
post #4 of 10 (permalink) Old 10-24-2013, 03:39 PM
Senior Member
 
Join Date: Feb 2007
Posts: 1,014
I didn't finish reading... You may be right lol

Sent from AutoGuide.com Free App

'06 Blue IRL
Build Thread
DFWGMElite Member
slitterell is offline  
post #5 of 10 (permalink) Old 10-24-2013, 04:03 PM
Senior Member
 
golden chicken's Avatar
 
Join Date: Feb 2007
Location: Acton, MA
Posts: 9,398
It's only an internet diagnostic, though.



Q: What's the difference between a bolt and a screw?
A: First, you screw. Then, you bolt.
golden chicken is offline  
post #6 of 10 (permalink) Old 10-24-2013, 04:48 PM
Member
 
Join Date: Oct 2013
Posts: 74
Does the car still accelerate in neutral all the way to redline? Can you still rev up in gear but go nowhere? Your clutch has gone south

Sent from Not Tapatalk 4
Bass_Waves is offline  
post #7 of 10 (permalink) Old 10-24-2013, 05:35 PM Thread Starter
Junior Member
 
Join Date: Oct 2013
Posts: 2
ok well sounds like I am screwed, but since I may have to get the clutched replaced anybody have any suggestions what kind of clutch I should put in?
jake.bowden is offline  
post #8 of 10 (permalink) Old 10-24-2013, 06:59 PM
Senior Member
 
qwikredline11's Avatar
 
Join Date: Jan 2008
Location: Ontario Canada
Posts: 4,728
gmpp upgrade from crate engine depot complete with throw out bearing. 275 or something like that best deal on the planet. 5 hours to put it in at a reputable shop.

qwikredline11 is offline  
post #9 of 10 (permalink) Old 10-24-2013, 08:19 PM
Member
 
Join Date: Oct 2013
Posts: 74
Quote:
Originally Posted by qwikredline11 View Post
gmpp upgrade from crate engine depot complete with throw out bearing. 275 or something like that best deal on the planet. 5 hours to put it in at a reputable shop.
Holds well with a turbo kit ?

Sent from Not Tapatalk 4
Bass_Waves is offline  
post #10 of 10 (permalink) Old 10-24-2013, 08:31 PM
Senior Member
 
qwikredline11's Avatar
 
Join Date: Jan 2008
Location: Ontario Canada
Posts: 4,728
its a clutch that the origin of, was the saab 9-3. Thats the 2.0 LSJ Style motor with a turbo in a heavier car. Yup I think it will work.
it does work and thats the truth. Not often you find bargoons like this GMPP upgrade clutch. thanks GM

qwikredline11 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Saturn ION RedLine Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Shaking during acceleration RedstickRedline Problems & Troubleshooting 19 07-02-2012 10:22 AM
acceleration issues scooterc14 Problems & Troubleshooting 16 01-26-2008 09:31 PM
Acceleration Hat. TWoods450 Off-Topic Discussion 4 10-04-2007 12:06 PM
stage 2 acceleration thedubsack85 General Discussion 0 06-29-2007 03:01 PM
Whirring upon acceleration IONTOP Problems & Troubleshooting 10 05-14-2007 09:50 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome