Saturn ION RedLine Forums banner
1 - 17 of 17 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 · (Edited)
Hello everyone,

My problem is unknown. Recently I have changed out the starter, fuel filter, fuel pump is good and even tried cutting the white wire (even thought it wasn't lighting up as an issue, only after I cut it, it lite up and said "service engine" we connected it back up and it went away) and had the ignition lock cylinder and ignition switch replaced since it was a recall item back in August. The problem started few weeks after that, no check engine light (no codes) but the car has a hard start.

Car sometimes will start on first try but if I turn it off and try to start it back up, no go. It will crank but won't start, I have to press the gas peddle all the way down and even then it struggles to start but it will start after a bit. Car runs great once it's on and won't shut off if it's just sitting, it just takes time to start it up Nad no missfires.

Anything I haven't covered or can do to figure this out I would gladly appreciate the comments.
:grim:
 

·
Registered
Joined
·
9,397 Posts
Figure out when it cranks but doesn't start if you have fuel and/or spark.
 

·
Registered
Joined
·
63 Posts
1st question is.. when you cant crank the engine over, do you still have power? does the gauge and dome light turn on still.. ?

2nd Question, have you had ignition recall done yet?
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #5 ·
1st question is.. when you cant crank the engine over, do you still have power? does the gauge and dome light turn on still.. ?

2nd Question, have you had ignition recall done yet?
Yes I still have power (had the battery tested it's fine) and yes had the recall done.
 

·
Registered
Joined
·
63 Posts
I was pretty sure their was still power in the system, just double checked

I had a similar issue but it was fixed after I took apart the power steering and clean it out with rubbing alcohol, their was aplenty of plastic shaving and gunk inside..(their a post some where here, it might be on the DIY section) the issue came back, the recall was done for me, and the issue hasnt came back yet.

how long ago was the recall perform?
 

·
Registered
Joined
·
9,397 Posts
how long ago was the recall perform?
I know you're trying to help, but you've asked 3 questions that were all answered in the original post.

Irandomized, is this a 2.2L Ion, or a 2.4L or a Redline? If it's a 2.2L, I'd suspect the ignition control module. If it's not a 2.2L, then possibly a crank sensor going bad, but some testing (looking for fuel and spark when the car acts up) or using a scan tool to look for pending codes might help.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #8 · (Edited)
I know you're trying to help, but you've asked 3 questions that were all answered in the original post.

Irandomized, is this a 2.2L Ion, or a 2.4L or a Redline? If it's a 2.2L, I'd suspect the ignition control module. If it's not a 2.2L, then possibly a crank sensor going bad, but some testing (looking for fuel and spark when the car acts up) or using a scan tool to look for pending codes might help.
The ignition module was changd out back in aug. of last year so its still fairly new.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #9 ·
I know you're trying to help, but you've asked 3 questions that were all answered in the original post.

Irandomized, is this a 2.2L Ion, or a 2.4L or a Redline? If it's a 2.2L, I'd suspect the ignition control module. If it's not a 2.2L, then possibly a crank sensor going bad, but some testing (looking for fuel and spark when the car acts up) or using a scan tool to look for pending codes might help.
Thanks for that ☝ lol. I have a 2.2L but I'm suspecting the crank sensor so I'll be checking that first then if it's fine I'll check the module. Stbm because I don't have a scan tool.
 

·
Premium Member
Joined
·
2,141 Posts
Thanks for that ☝ lol. I have a 2.2L but I'm suspecting the crank sensor so I'll be checking that first then if it's fine I'll check the module. Stbm because I don't have a scan tool.
I had an ion 2.2 for several years prior to redline

I had about 4 times an ignition module replaced - think I was left in the middle of 3 highways at times - fun stuff

each time - I was told that the ions are known for ignition problems

(in addition to the recall problem)

...just my story
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #11 ·
I had an ion 2.2 for several years prior to redline

I had about 4 times an ignition module replaced - think I was left in the middle of 3 highways at times - fun stuff

each time - I was told that the ions are known for ignition problems

(in addition to the recall problem)

...just my story

Thanks for that but I'm assuming from what you typed your car was shutting off on you, right? My car isn't shutting off, once it on its on but I will check the module thoough, never hurts to look.
 

·
Premium Member
Joined
·
2,141 Posts
Thanks for that but I'm assuming from what you typed your car was shutting off on you, right? My car isn't shutting off, once it on its on but I will check the module thoough, never hurts to look.

For me it was not shutting off - just complete failure (no indication that there was a problem

prior to failure)

...I quess it was the electrical or electronics

that went...

There was also a problem when brand new in the cold that created start

problems

not sure why and no one ever said the reason but they kept replacing

these modules
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #13 ·
I had an ion 2.2 for several years prior to redline

I had about 4 times an ignition module replaced - think I was left in the middle of 3 highways at times - fun stuff

each time - I was told that the ions are known for ignition problems

(in addition to the recall problem)

...just my story

It ended up being the crank sensor, replaces and now the hard start issue is gone. Thanks fellas!!
 
1 - 17 of 17 Posts
Top