Saturn ION RedLine Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter · #1 ·
Just bought an 06 Redline that seems to have several modifications including: ZZP tune, liquid innercooler, smaller pulley, ZZP motor mount, boost gauge/ shift light kit, etc. The car is not running and according to the last owner its due to the "failed" ignition module on steering column. I see the vehicle has 3 open recalls all related to this ignition system, however with the installation of the boost/ shift kit on top of the steering column, I assume the dealership will deny the claim. I am in the process of removing it and getting the wiring there back to stock.

The biggest issue I am faced with is the fact that the odometer has no display. Without this I cannot transfer ownership at DMV because it has a California title and I am in Nevada. It requires a VIN check that cannot be done without known mileage.

Anyone know if this wiring for the boost/shift gauge is any way "tapped into" the signal feed to the odometer display?

All of the wiring done to this car does seem to be done well and clean, but I have no data from the ECM on my scanner. It has a new ECM from ZZP that made no change in symptoms. I am slowly looking for the "dropout" culprit for no ECM or odometer. I am not even sure if issues are linked.

I do engine mechanical and all this electronic headache is out of my wheel house. Any ideas or troubleshooting tips are welcome.
 

·
Super Moderator
Joined
·
1,499 Posts
So just nothing is showing on the dash at all? Like fuel/temp etc?
The ladder tach and boost gauge. Is it stock? The competition packages came with those. And the car should not be denied the recalls because of that. Actually. They can not deny recalls period.

If they wired the tach/gauge as per instructions on here it should not be tapped into the cluster for power.

And the pcm, its not communicating at all?
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #3 ·
I have all other dash lights. I have no odometer or messages in the display.

My scanner has no communication with the ECM.

The ignition is very hard to turn with key. The only thing that happens when key is forced to turn is that the power locks activate.

I didn't know that the boost/shift combo was a factory option.

If I can get an odometer reading and the car into my name, li can get it in for the recall.
 

·
Super Moderator
Joined
·
1,499 Posts
The odometer reading can be pulled from the bcm where it is stored.
But you would need a GM tech 2 for that as far as I know.

Is your car a competition package?

Have you checked all pcm/ecm fuses? Not completely unheard of to for a pcm to be bricked. But not likely as zzp checks them before shipment
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #5 ·
I am not sure if it has that package or not.

On all otje GMs I work on I can access mileage, VIN, options, etc w my programmer. This PCM I cannot through the OBD port.

I will attempt to communicate w the trans module, BCM, or anything else in the stream.

I am fighting several battles because the last owner tried "fixing" multiple things and not diagnosing the actual problem.

I jumped the starter and verified compression is good on all 4 holes. I did this because I have had sellers "disable" a vehicle they selling to hide a bad engine.

I do believe this an electrical issue. I just wish I had more training on that side of the engine.
 

·
Super Moderator
Joined
·
1,499 Posts
If you look at the trunk tag on the driver side for code "g85" it will indicate a comp package model.

I understand. I'm taking my electrical classes now through Toyota where i work and theyre driving me crazy because of how bad i am at it and easily get frustrated with it
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #7 ·
I dug in and corrected all the wiring in the Redline. Boost gauge and shift light turned out to be a stock item so I kept them.

The ECM was dead so I ordered a replacement unit from ZZP.

Still no start after it was installed. Next I towed to local Chevy dealership and had the ignition recalls performed. Service advisor called after ignition was replaced and claimed still wouldn't start and needed an ECM. Wanted $875 and was surprised when I declined and towed home.

I was miffed that my diagnosis of ignition was wrong and started troubleshooting. I found that the fuel pump fuse was blown. 🤬 I am 100% certain it was not prior to towing to dealership. I checked ALL fuses and relays when I went through the process of trying to get it running again.

Dealership has ignored my request for info on how this occurred and how their diagnosis of ECM was so far off.

As far as the odometer not working, I decided to hit my local pic a part and get a donor instrument cluster. All functions returned. I ordered a new on from a different dealership. It will be here Tuesday after its programmed for the mileage.

Then after the odometer finally shows mileage, I can get the VIN check completed and title into my name and finally sell it!

Thank you all for the PMs and input to help me on this matter.

If anyone is looking for an Ion Redline, LMK
 
1 - 7 of 7 Posts
Top