Saturn ION RedLine Forums banner
1 - 4 of 4 Posts

· Registered
2007 Saturn ION Sedan 2.2
Joined
·
3 Posts
Discussion Starter · #1 · (Edited)
Working on a 2007 Saturn Ion Sedan 2.2L Ecotec with 190,000kms(roughly 118,000 miles), car starts fine shortly after it starts within 40-50 seconds when cold but if restarted when car was just running it starts 10-15 seconds after the RPM settle it starts to chug and try to die but only at idle or st a stop car drives fine otherwise been diagnosing this for a few weeks I wish I had my good OBD2 scanner with live stream data to watch fuel trim/o2 sensor voltage /CKPS voltage etc but might have to go through rhe car with a multimeter but figured I'd post the issue with video incase someone may have ran into similar issue it kicked the bucket after so many years only have cheap code reader that can only read an clear codes only code have on is one that has been on for 4 years and never ran into any problems tell now.

-Recent maintence done 15,000km ago - Plus gapped changed

-Fresh Oil changed regularly every 4k-5k and was just done little over 1k ago

- Part of troubleshooting issue last week I changed out Fuel filter, cleaned up pump checked pressure it's fine.

- Sprayed around areas with starter spray and throttle cleaner to check for Vaccume leaks/ Faulty Senors / Clogged or Dirty TB Clogged or Dirty Injectors and bad grounds checking whatever basics I could.

- Made 2 quick videos uploaded to yotube of driving and idling conditions and attached links in message, I realise its very hard to hear much in video cause blower for heater turning and whistling lightly combined with loud winter tires at -18°C makes it hard.

- Next move is to inspect IAC Solenoid and 02 sensors and revisit the investigation into the 4 year old code that kept coming back with no noticble issues.

- I'm hoping someone may read or see this and by some miracle know what's going on with it save me time.

Old persistent OBD2 Code and Definition :--

P0315 code indicates that the crankshaft position sensor (CKP sensor) has gathered certain information about your crankshaft position that wasn't actually stored in the memory of the powertrain control module (PCM).

Any help tips or pointers would be greatly appreciated thank you.

Just Incaee the Links don't post correctly:

Youtube Video Part 1:

Youtube Video Part 2:
Tire Wheel Automotive lighting Automotive tire Hood
 

· Super Moderator
Joined
·
1,893 Posts
Have you tried swapping the crank sensor? Good chance it may have jumped time a tooth or two.
 

· Registered
2007 Saturn ION Sedan 2.2
Joined
·
3 Posts
Discussion Starter · #3 ·
Have you tried swapping the crank sensor? Good chance it may have jumped time a tooth or two.
That is my next move and I don't believe it jumped any teeth as it starts up idle js ok for minute or so then it like starts to go chug chug chug chug bht won't shut off hand ti exain I'm sorry for the weird shit in says but like lol I watch rpm guage might give yoh a idea first start uo ies at maybe 1000 or so in the cold so 1000 steady 40 seconds fine no issues then 20 seconds might rol 900 its fine then goes 700-500 700-400 up and down is it's doing its rough idle so if timjnf was off I would imagine the car would run like shit soon as you turn the key lol but the sensor CEL Been on 4 years or so I checked it bsck then but it checked out volt testing so I ignored it 4 years later same code still but I mayell start from there just covering all basis before I start throwing money at it
 

· Super Moderator
Joined
·
1,893 Posts
Check the crank sensor for power and ground. Clean the throttle body and do a relearn. Clear the codes and start it back up, see if anything pops back up.
Check spark and fuel pressure to be safe.
 
1 - 4 of 4 Posts
Top