Saturn ION RedLine Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
ok so i rremoved my gf's air box in her redline and now when you are coasting in 3rd gear with your foot all the way on the clutch the revs go up and down from like 500 rpm to like 1500 up and down it when to 0 once or twice and the car stalled while having the clutch pushed to the floor the battery also came on well once you remove your foot off the clutch everything is fine.. the car dosnt run rough or anything like that ..... also the check engine light came on now this leads me to the conclusion that its sucking to much air and the ECU cant keep up... or i might be way off i was thinking about getting maybe an engine management system or something or reprogramming the ecu to adjust for the massive air flow...... PLEASE HELP ME ANY THOUGHTS OR COMMENTS THAT ARE HELPFUL ARE GREATLY APPERICATED..... the car runs fine minus the idle surges in third (and second) :confused:
 

·
Super Moderator
Joined
·
4,617 Posts
Does Jiffy Lube have a code reader? Best bet is to see what it is and if it's serious take it to Saturn.

Also, Blackline saw her Red Line at Jiffy Lube and made a post about it.
 

·
Registered
Joined
·
3,574 Posts
Dude!!! Mine is doing the same shit.

It never did it before after the airbox removal but about a week and a half ago, my K&N filter came off and the car ran like shit. I took it home and put it back on and ever since then my car does this. It's only sometimes and I have an intermittent CEL as well. My car has also done the clutch in stall twice in the past few days.

I'm gonna take mine to the dealer either tomorrow or Thursday.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #4
good luck with that man b/c they said they wouldnt touch my gf's car b/c it had a "aftermarket air filter" on there so if you have a K&N and a warranty they wont touch it...
 

·
Super Moderator
Joined
·
4,617 Posts
ProjectRedLine04 said:
good luck with that man b/c they said they wouldnt touch my gf's car b/c it had a "aftermarket air filter" on there so if you have a K&N and a warranty they wont touch it...
Magnuson-Moss Act. Mention that, if they still don't want to. Then you print out the details and hand it to them. Saturn of Dayton South gets on my nerves sometimes.
 

·
Registered
Joined
·
3,574 Posts
ProjectRedLine04 said:
good luck with that man b/c they said they wouldnt touch my gf's car b/c it had a "aftermarket air filter" on there so if you have a K&N and a warranty they wont touch it...
My friend's brother is a tech at Saturn of Fort Worth, where I take my car. I have no problems with that sort of BS at all. :p
 

·
Registered
Joined
·
786 Posts
Dude, first get the latest OBD upgrade and see if it subsides. Then tell the dealer about the Magnuson-Moss Act. If they resist, then I can tell you from experience, call Saturn in TN and tell them your son jacked up your car while you were rotating your tires and while you were in the house he ruined the airbox by jacking up the car and you had to pull it out in order to go to work. You didn't have the cash to replace it so you did the best thing you could and put a (what ever filter on it) and you have every intension of installing an OEM unit or a K&N unit as soon as the funds arrived.

Let me know how things work out. I have a flare for that kind of thing......won't tell you what I do for a living..........
 

·
Registered
Joined
·
3,574 Posts
I've got a sevice appointment at Saturn of Fort Worth at 10am tomorrow. I'll let you know what they say about it.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #9
i unplugged the MAF and re pluggerd it in there but i made sure it was on there good and the check engine went off i dunno if the ecu just readjusted its self or what but so far its fixed the problem "knock on wood"
 

·
Superd00d
Joined
·
22,040 Posts
ProjectRedLine04 said:
i unplugged the MAF and re pluggerd it in there but i made sure it was on there good and the check engine went off i dunno if the ecu just readjusted its self or what but so far its fixed the problem "knock on wood"
Good call... make sure that shizzle is tight...
 

·
Registered
Joined
·
3,574 Posts
They have no idea why my car is doing this. I was at the dealer for 3.5 hours this morning. They did the camshaft seal recall on my car while I was there though.

They reset the computer and said the CEL code was bank 1 running rich and then bank 1 lean.
 
1 - 11 of 11 Posts
Top