Saturn ION RedLine Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
3,574 Posts
Discussion Starter #1
Well, I removed my airbox yesterday and drove a total of 50 miles to work and back with no SES light to speak of.

Today as I was driving on the freeway, no sooner than I thought to myself, "Cool, the light hasn't come on", I look down at my gauges and it's staring me in the face.

How did you guys get rid of it? Or does it just take the computer a while to get used to the extra air flow sensed by the MAF and eventually cut off on its own?

I know it's no big deal but the little light there does kinda bug me. :eek:
 

·
Premium Member
Joined
·
3,231 Posts
havent had any problems yet. Is your MAF pointing the correct direction 100% make sure of that first. Worst come to worse go to autozone get it read for free and find out what is causing the light. Perhaps its not your Airbox at all.
 

·
Registered
Joined
·
3,574 Posts
Discussion Starter #3
goofyguy said:
havent had any problems yet. Is your MAF pointing the correct direction 100% make sure of that first. Worst come to worse go to autozone get it read for free and find out what is causing the light. Perhaps its not your Airbox at all.

Well, I had the light come on for a bit when I first put the K&N in the airbox. It went away though. Now that I have removed the box, I'm assuming this is what is causing it.

I may swing by Autozone tomorrow and have them do that for me.
 

·
Registered
Joined
·
114 Posts
jsut disconnnect your negative battery cable for ten minutes and put it back. My ses light popped on after i did this mod and i undid the battery and it never came back...
 

·
Registered
Joined
·
3,574 Posts
Discussion Starter #6
spongalot said:
jsut disconnnect your negative battery cable for ten minutes and put it back. My ses light popped on after i did this mod and i undid the battery and it never came back...

Just did that. Friend at work suggested it and it worked.

Thanks.
 

·
Registered
Joined
·
3,574 Posts
Discussion Starter #7
[email protected]#K!!!

It threw the light again this morning when I was taking my daughter to school.

Do you have to do the battery reset more than once?

I'm gonna take it to Autozone later and see what code(s) it gives me unless someone could suggest something else.

:mad: :mad: :mad:
 

·
Registered
Joined
·
1,135 Posts
its been happening to me too, all it is is a light that says ur running rich......and our cars run rich anyway.

it doesnt affect gas mileage, i checked.


and the light will go off, it comes and goes as it pleases, i wouldnt worry too much about it......one of these days someone will come out with a solution to it, once the intakes come out im sure that will all go away.
 

·
Registered
Joined
·
3,140 Posts
let me guess, it happens when at a cruise on the freeway, or higher speed in 5th, just keep clearing the codes at your local auto parts store, eventually the cpu will relearn the a/f curves or whatever, mine hasn't gone on in a while, don't disconnect the battery, because it's going to try and relearn it, i did it a couple times. basically, you're better off to just leave it, i noticed if i get on it on an onramp from a stop, it goes away, only to come back on again. mines been off for about a week now, and i've driven the same routes a few more times and no light
 

·
Premium Member
Joined
·
3,231 Posts
how close is the MAF to the air filter?
 

·
Registered
Joined
·
3,574 Posts
Discussion Starter #12
goofyguy said:
how close is the MAF to the air filter?

The MAF is on the airbox lid, same as it was stock. The only thing I did was remove the airbox from the the engine bay and snorkel setup from the wheel well.


The light turned off just now when driving home.
 
1 - 12 of 12 Posts
Top