Saturn ION RedLine Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
So, after getting my car out of the body shop, I have my power steering fixed but my key locks in my ignition, but before i got that fixed i was having to disconnect the front battery cables (by the fusebox area; due to my key being locked in the ignition and my trunk latch is broke, my electric pop does not work.) i actually had the cables touch the back of my ECM which caused a short to my BCM & ECM, also caused a small fire which melted my cables by the starter (or so we think). I have replaced the ECM w/ a stage 2 ZZP trifecta tuned ECM (modding to S2) and a BCM from an 04 ion RL everything lights up and wants to turn on but it doesnt want to start. When my mechanic plugs in the diagnostic it says no response from the car, how is this true?
As well as GM has tried to tune the BCM and still no response from the used BCM, i think it the harness, and this is my first RL and i feel like ive fucked up big time, anyone have any solutions? im up for anything right now. ive been without it for a month
 

·
Registered
Joined
·
4,362 Posts
Is the PCM trifecta tuned or zzp tuned?
You mat not have the correct VIN # in the PCM causing a anti theft issue. Is the BCM programmed for your car?

AS stated above the PCMs are almost yr specific. 04 is 04 05-06 interchange and 07 is also by itself I believe.
 

·
Registered
Joined
·
4,362 Posts
If i had any melted wires around the PCM connectors melt, I think I would go ahead and replace that engine harness.
 

·
Registered
Joined
·
4,362 Posts
1 - 7 of 7 Posts
Top