Saturn ION RedLine Forums banner

1 - 18 of 18 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hello,

I recently purchased an 04 RL (31K Miles @ purchase), and have since had a problem I can't seem to fix... I've searched, and found nothing similar to my problem, so here goes:

The problem SEEMED to come out of no where (no work done to car right before problems), and has rapidly gotten worse.

Car runs perfect 95% of the time, has new plugs, new air filter (K&N, stock housing), no performance issues etc etc. I had the cold start problem due to passlock, but after cleaning the switch (thanks to some helpful guides) that was gone. Now, randomly while idling (moving or nonmoving, but never while in gear accelerating), the car will shut off - no sputter, just dies.. after attempting to start the car again, it wont turn over.

After it happens, the car wont turn over at all. I can hear the relays click, but starter doesn't go. I have all on board lights still, passlock is NOT lit like it was when it was a problem.. it seems after a few minutes it will start back up, but likely dies several more times before staying alive and driving perfectly again.

I have tried swapping relays, checked connectors under the fuse box for loose wires, checked terminals on the fuse box for any resistance, checked battery terminals for loose connectors.. i tried tapping on relays when it would die (with new ones, and switching them around), or jiggling around the wires to see if I could get it to start, but it doesn't ever seem to work consistently. I will inspect the engine ground and all the connectors more thoroughly tomorrow, but I know if I take it to a mechanic it won't die for them. Gotta have the magic touch, I suppose...

sorry for long post... just trying to be thorough.. lmk if more info is needed.
any suggestions?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
Hmm. Well I read that code is ecm rom check sum error, but i was looking for more input than "theres your problem".

would flashing possibly fix it, or does it need to be replaced?
best to order online somewhere, or directly from stealership?
anyone has experience with this issue?

any info would be helpful.
 

·
Registered
Joined
·
905 Posts
Taken from a google search.
A code P0601 in most cases means the PCM has gone bad. This is possibly due to a short-circuit inside the PCM. Or, if you disconnect the wires/connector from the PCM while the battery is still connected, that may also cause this code.
You can probably find a used one.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #8
Some information in case anyone else has this problem:

After checking all the connections on the ECM, I ordered one from zzperformance.com. I figure its defective, but in the mean time a quick fix is to spray the large silver heat sink with a can of compressed air upside down... if it dies, cooling down the heat sink allows the car to run again - and so long as I am moving, the air is enough to cool it down (it seems... it never dies while driving).

I'll report back with the results of the new ecm.
 

·
Registered
Joined
·
235 Posts
im having a similar problem but my car refuses to start but it IS turning over. i have fuel, power etc, and every once it a while it will bam fire up and run and drive like theres no problem, then sometime during the drive poof dies.. and wont start again, again the starter is turning and everything but car wont actually start, or stay running for any long period of time if i can manage to get it to start.. does anyone have any ideas?
 

·
Registered
Joined
·
4,362 Posts
Retard, do a compression test and take a look at your plugs while you're doing that.
I would clean your grounds and actually do a fuel pressure check, with a guage.

@ Insta, are you just getting a replacement PCM or getting some performance goodies too?
 

·
Registered
Joined
·
9,397 Posts
im having a similar problem but my car refuses to start but it IS turning over. i have fuel, power etc, and every once it a while it will bam fire up and run and drive like theres no problem, then sometime during the drive poof dies.. and wont start again, again the starter is turning and everything but car wont actually start, or stay running for any long period of time if i can manage to get it to start.. does anyone have any ideas?
Again, basics. Air, Fuel, Compression, Spark. Make sure you have all of them in the right order.

And have it scanned for codes in case there's anything like a P0601 we should know about.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #12
Retard, do a compression test and take a look at your plugs while you're doing that.
I would clean your grounds and actually do a fuel pressure check, with a guage.

@ Insta, are you just getting a replacement PCM or getting some performance goodies too?
Tried to keep the options on the part basic, but i guess its more performance tuned than the stock pcm. Should be coming tomorrow, unfortunately I'll be out of town for the rest of the week. :\

In the meantime, I've confirmed that cooling down the heatsink with canned air does the trick - it died, wouldnt start... i felt the heatsink and it was very warm (and judging by the material, i guess its not super heat conductive... so the chips are probably suuuper hot)... sprayed the can upside down till the ice didnt melt instantly and blagow - started like a champ.

Now i've got my mechanic in a can sittin in the front seat with me :redblob:
 

·
Registered
Joined
·
235 Posts
Someone told me it could be the fuel pump.. although I can hear it kick on when I turn the key forward. Could it still be the fuel pump?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #15
Someone told me it could be the fuel pump.. although I can hear it kick on when I turn the key forward. Could it still be the fuel pump?
Your problem is certainly different than mine, ... retard.

Do exactly what golden chicken said: check air, fuel (not just in the tank, but is it getting to the injectors, etc), compression, spark...

Also, as far as getting a code, you can take it somewhere or just buy a code reader.. worth the investment to save you the worries.
*cough*
heres one
*cough*
 

·
Superd00d
Joined
·
22,040 Posts
I had the exact same issue one time, same code. Never happened again. I was also advised to make sure the battery connections were tight.
 

·
Registered
Joined
·
235 Posts
my issue was a fried powertrain relay? was apparently keeping the car from starting, also i guess i needed the most recent PCM update. these were the only 2 things done and car runs like a charm again... Electrical stuff hate me
 

·
Registered
Joined
·
235 Posts
5 codes..

ok ran my car for codes and got 5.. first one
p0420 catalyst system low efficency... expected i have no cat.
p0017 crankshaft position timing misalignment..
p0446 EVAP vent system performance..
p1182 SUPERCHARGER INLET PRESSURE SENSOR PERFORMANCE..
p0068 MAP/MAF throttle possition correlation..
well... from my sysmtoms and what its saying here i think its safe to say that maybe my crank sensor needs replaced, and i need to change my air filter and clean my MAF sensor (live on dirt road) does anyone know where the crank sensor is?????
 
1 - 18 of 18 Posts
Top