Saturn ION RedLine Forums banner
1 - 10 of 10 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
My 06 Redline is showing a P0172 code.
Has a rough idle & dies most of the time it is at a full stop or parked. It also putters at 3000 rpms in 2nd through 4th gear and doesn't get up past that once it putters. I tuned it back to stock. I've cleaned maf & intake filter. Changed spark plugs and O2 sensor. There are no vaccum leaks. Idk what it is. Any Suggestions?
 

·
Super Moderator
Joined
·
1,810 Posts
thats a rich code.
what are your mods?

have you checked the fuel injectors?
 

·
Premium Member
Joined
·
2,266 Posts
That's actually the infamous poor code - I had that one time, before I had done the "upkeep"

the redline requires much attention
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #4 ·
thats a rich code.
what are your mods?

have you checked the fuel injectors?
I'm not too sure about modds. None that I can visually see. I bought the car a couple months ago and I'm also new to fixing cars. Kinda why I bought this one, to learn more. I haven't checked the injectors yet but I will and I'll let ya know
 

·
Super Moderator
Joined
·
1,810 Posts
Feel free to post a picture of the engine bay.

Its either going to be in the intake system or the fuel injectors.
Make sure theres no breaks in the intake. Pull the throttle body off to clean it, dont move the butterfly.
and can probably grab some injector cleaner to put in the tank.

You are running 91/93 yea?
 

·
Premium Member
Joined
·
2,266 Posts
All of the general upkeep has been done to it.
Any suggestions?
I actually don't know why the code went away - I also had a bad CAT that may have influenced the upkeep. I had done several things over about 6 months and it went away.
 

·
Premium Member
Joined
·
2,266 Posts
Feel free to post a picture of the engine bay.

Its either going to be in the intake system or th gb fuel injectors.
Make sure theres no breaks in the intake. Pull the throttle body off to clean it, dont move the butterfly.
and can probably grab some injector cleaner to put in the tank.

You are running 91/93 yea?
don't move the butterfly ? I probably commented before with you about this but I always move it to clean it better -disconnected power
 
  • Like
Reactions: silverredline06

·
Super Moderator
Joined
·
1,810 Posts
I was always under the impression that it can mess up the calibration. But I guess if youve got the power disconnected, itll have to relearn everything anyway
 
1 - 10 of 10 Posts
Top