Saturn ION RedLine Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter · #1 ·
I have been dealing with o2 sensor heater codes for a while, the wires are good and new sensors didnt fix anything, i even checked the emiss fuse, no issue.

now im getting a coolant message in my dash, but the coolant bottle and sensor are both brand new.

it also throws a map/maf code, and some other powertrain codes.

Think its the PCM? It could be the original 17 y/o PCM...
 

·
Super Moderator
Joined
·
1,498 Posts
Check your grounds lately?
 

·
Super Moderator
Joined
·
1,498 Posts
Id go over all them. Could try adding one from pcm to chassis
 

·
Super Moderator
Joined
·
1,498 Posts
A couple grounds were added to my base model and it cleared up some random codes id get out of no where. So it may help
 

·
Registered
Joined
·
35 Posts
Discussion Starter · #7 ·
Awesome. ill try that tomorrow then, hopefully she runs better after

might do a pcm anyway due to it having an intake and full exhaust tho
 

·
Super Moderator
Joined
·
1,498 Posts
If you have a tuner local, can find a pcm cheap and have that one tuned. Or get a zzp one then get a street/dyno tune
 

·
Registered
Joined
·
30 Posts
my exhaust manifold was starting to crack. I did not know (because the flex pipe was leaking) until I got an upstream O2 code. Went cheap and bought an SMP sensor and immediately got an O2 heater circuit code. Bought an NTK sensor (actually the AC Delco brand)and swapped over to a stainless header, fixed the problem. AND, Flagship One is selling plug&play PCM's for $150 for the '04 redlines right now.
 

·
Registered
Joined
·
30 Posts
There you go. There are way too many threads about intercooler pumps. I pulled a smaller one out of a Lincoln LS I found in a salvage yard and half bolted it to the bracket. Been working for over two years now.
 
1 - 11 of 11 Posts
Top