Saturn ION RedLine Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hello,

I've got an 04 Ion Redline with 195,000 miles on it and it's rusty, but runs great.

My gear box is making a grinding sound at idle. In gear and if I move the stick around it stops, but if I press and release the clutch at idle it starts again. I changed the transmission fluid and found it was a little low. I haven't been able to drive it except up and down the drive way due to suspension problems. Any ideas on what is wrong with it?

I'll be pulling the engine/transmission out in the near future to change gaskets and bearings and just want to have the right stuff to fix it up nice.

Thank you
 

·
Super Moderator
Joined
·
1,498 Posts
Sounds like the slave cylinder is starting to go. Super common on these
 
  • Like
Reactions: Josiah of Judah

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Awesome! I've already got the whole clutch replacement kit including the slave cylinder.
Anything else I should be looking out for or do while I'm at it?
 

·
Super Moderator
Joined
·
1,498 Posts
Axle seals probably wouldnt hurt if you were in there as well. Might consider some new shifter cables as well.
 
  • Like
Reactions: Josiah of Judah

·
Super Moderator
Joined
·
1,498 Posts
Yes
 

·
Super Moderator
Joined
·
1,498 Posts
Not to the body no.
Need different trans mounts, the saab cables and shifter.
And im like 90% sure you'll need the saab axles and clutch/flywheel
 

·
Super Moderator
Joined
·
1,498 Posts
That one I dont think so. Think that was a v6?
 
1 - 10 of 10 Posts
Top