Saturn ION RedLine Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1 (Edited)
I'm having some trouble diagnosing the cause of my oil leak.

162k, so the problems are bound to start sometime, but over the last few years the car has been leaking oil, nothing too serious until about the last year or so. Its pooling around the filter cap and only really leaks when i drive the car. If its sitting in my garage, its only really dripping after a drive. I've just changed the oil roughly 3 weeks ago, and the oil light has already gone off.

Few ideas:

My brother (original owner) claims its the rear main seal. According to the extent of my research on here, this could very well be the problem.

It could be the filter cap and o-ring, but I highly doubt this because I've changed that o-ring every oil change. I could've tightened the cap too loose or too tight -- and cause the o-ring to be ineffective -- but what are the chances of me doing this on the last 4-5 oil changes?

I went in to a local auto shop and 2 mechanics and the owner looked at it. They said they couldn't confirm the rear main seal, but he said, "its 100% a oil filter housing seal."
I have no idea what this is.

http://www.crateenginedepot.com/pdfs/LSJ_Cylinderblock_and_Internal_parts.pdf
http://www.crateenginedepot.com/pdfs/LSJ_Oilpump_Oilpan_and_Relatedparts.pdf

According to these, the filter housing is part of the block, and the only relevant seals seem to be the rear main seal and the filter o-ring.

Any opinions would be greatly appreciated. Thank you.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Currently I have a Wix filter in there, but I haven't exactly stuck to one brand. I just usually buy what's cheapest/available.
 

·
Registered
Joined
·
9,397 Posts
I've found some cheap brands' filter cap o-rings are too small and leak a ton. Clean up the mess and put a Hengst in with a new o-ring and see what happens.
 
1 - 4 of 4 Posts
Top