Saturn ION RedLine Forums banner

1 - 20 of 33 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
ok this car seriously just needs a match in the fuel tank already...

FROM DAY ONE!
Bought the car from local dealership.. drove it off the lot and bam engine blew! put a hole in cyl 1 putting all the compression into the oil pan, blew out the dipstick and all the oil out the dipstick tube.. ok so dealership paid for a "new engine" in all reality they got a used engine from a local scrap yard...

they went $10k under the hood of this thing trying to get it to run proper.. never got it runing proper.. seemed ok but had a lean code *was just a bad sensor* got rid of that, but the car seemed to have less power with the new engine then the old one.

now alla sudden bam car has ZERO power, the supercharger does NOT sound proper what so ever, missfiring, boggiing cant get 30km, barly get the clutch out n she almost dies, cant hit 1/4 peddal or it does die.
this just happend at random..

CODES
P0335
P0171
P0300
P0326
P0496

What are the chances my timing belt skipped

OR

did i blow out my charger??

keep in mind i have the 2.0L supercharged running GM bolt on stage 2 kit, and cold air intake...

what may have gone wrong!!!
 

·
Registered
Joined
·
4,362 Posts
Your engine has a timing chain, so I would say very unlikely.
Are all of the vacuum lines plugged in and routed correctly?
Not knowing what has been done with the car, I would either get a OEM stage 2 tune flashed on the car or go back to stock and diagnose from there. A poor tune may have killed the first engine also. I'm sure it was traded in for a reason.
 

·
Registered
Joined
·
4,362 Posts
What Cold air intake are you running by the way?
 

·
Registered
Joined
·
2,034 Posts
Before you drive yourself crazy trying to figure out what is wrong, why don't you just have the dealer properly fix it? How long ago did you buy the car and is it still under warranty?
 

·
Registered
Joined
·
16 Posts
Discussion Starter #5
recaro86 - its had this set up apparently since it was new.. not sure why it got traded off, but i do know since trade off a guy bought the car, couldnt pay for it, and it became a "volenary repo" *guy addmited to driving 1hr on the highway 3rd gear at 6000rpm* wich must have weakend the engine, causing it blow up a pistion, so being bought this way, no way i can go to stock, due to lack of factory parts *we cannot find anouther engine in all of saskatchewan* also not sure of the exact model of cold air intake, but i do know its a k&n system, and goes up into the drivers fender! f

ever since day one of getting my car back with this new engine, its always blew a tiny bit of blue only on the first start of the day, unless its real cold out * i do live in sask* then its black from over fuel... with the old engine the car ran 135kpa boost, after the engine swap it only hit 120kpa, so theres one issue from start, then the other day i heard a small clicking sound sounded like it came from the charger, but that went away didnt think anything of it, then all of a sudden i go to drive away from a red light and my car bogged haaarrrdddd then since that moment, check engine flashing at random, and the charger sounded piss poor, weak/higher pitch sound... but still look at the boost gauge seams to be boosting still... and who knows about the vacume lines.. from everything els that dealer messed up in this car i wouldnt doubt it... they left the whole subframe loose, every motor mount was loose, and both balljoints were loose. sounded like the whole front end was gonna fall out of it!! i had to go under and tighten it all my self, dealer refused to do it!


Vyperpunk - i bought the car maybe 2 months ago, and have only been able to drive it for 3 weeks of that, after the dealer dropped $10k into the car after selling it to me for 9k, they were pretty pissed off, and refuse any more work to be done on the car... and being a 2007 staged redline with 94,xxx km on it theres no GM warranty either!


i am at a major stump! if its something wrong with the engine i can get it replaced no charge by the scrap yard that sold me the engine... if its my charger im screwed and im paying for this all my self, ugh!
 

·
Registered
Joined
·
16 Posts
Discussion Starter #6
i will take a video of my car, with it running.. for you all to hear what it sounds like.. and its piss poor running condition.. and i will post it up on youtube, ill paste the link on here when i got it posted!!!! more or less in the afternoon tomorrow sometime!
 

·
Registered
Joined
·
4,362 Posts
The boost issue is weird, when they swapped the motor did they not keep the original supercharger/pulley that was on the first?
Yeah k and n should be fine as a intake. The blue smoke indicates a tired engine also or blow by resulting in oil consumption. Stock parts are very cheap, injectors and a pulley are all you would need to go stock and injectors can be had for 50 bucks. It sounds to me like the pulley may be stock size with this "new" motor-explaining the power and boost differential you described above.
Pics of engine bay/vids may prove to help some more
 

·
Registered
Joined
·
16 Posts
Discussion Starter #8
well actually, they did reuse the original charger*the one that was on the car with the reduced pully* , new engine didnt come with one attatched to it.... they tried using the factory injectors that did come with the new engine, and they couldnt figure out why it was running so rough, and lean... *even tho i told them they HAVE to use MY charger AND MY injectors* they niglected to swap the injectors untell i got pissed off and told them do so, *ofcourse solved that issue!* so yea most deffintly they used my charger and my injectors.. so there really shouldnt have been a boost differance :s

maybe the other engine may have had some other work into it? i dont know lol but yea k tomorrow i will post a video up on you tube :) thanks!
 

·
Premium Member
Joined
·
898 Posts
Im not sure about the boost issue, Maybe check the SC gasket and all the vac lines. But my first step would be to check the plugs. They prolly used the plugs in the salvage engine and they could be bad. Start with some stock heat range NGK gaped to .040 and go from there. And have a compression and leak down check done.
 

·
Registered
Joined
·
2,034 Posts
How likely is it that the dealer snatched a random engine from any ion they found at the scrapyard (like the 2.2). The lsj engine isn't very common to find in a junkyard.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #11
Well they also replaced the gasket.. And no it was the charged engine.... came with the charger intake on it
 

·
Registered
Joined
·
2,034 Posts
OK, just had to make sure. As suggested before, if the engine itself is in good shape, you might as well just pick up some new injectors and a good tune. A good thing to start with is a compression test.
 

·
Registered
Joined
·
1,014 Posts
P0335 Crankshaft Position Sensor A Circuit Performance
P0171 Lean
P0300 Misfire
P0326 knock cannot be eliminated with timing
P0496 high evap flow

I would, though, run a leak down and check your spark plugs to see what is happening inside, then change the spark plugs.

Are you saying the dealership won't mess with it anymore?
 

·
Registered
Joined
·
16 Posts
Discussion Starter #17
Dealer won't touch the car, what so ever. they paid out additional 3k towards buying out my warranty cause they voided it
 

·
Registered
Joined
·
2,034 Posts
Hm... I think that's bullshit that these guys are refusing to work on your car. If they give you a warranty, they are responsible to uphold the terms under the warranty.

Honestly though, there are a few inexpensive fixes you can try. Change the plugs, replace the fuel filter, replace evap/purge solenoid. But before you do all of that, definitely get that leak down and compression test done. That'll at least give you a rough idea how the engine is holding up.
 

·
Registered
Joined
·
4,362 Posts
Wow that girl is running tough.
Check compression
Check fuel pressure
They say to always fix the lowest numbered code first, you either have a spark issue or a fuel issue the way that is cutting out/loading up.
I stand by my original post to get a stock set of injectors and throw a stock tune on it. Diagnose from there, (because you will know what you have) the pulley on it will be fine as long as long as you aren't romping on it for testing purposes.
 
1 - 20 of 33 Posts
Top