Saturn ION RedLine Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
786 Posts
Discussion Starter #1
I'm going to the dealer again for the second time, no brake lights! It sucks almost getting rear-ended. Also there's hesitation on the highway every 10 seconds or so. It spits, if you know what I mean. Runs like shit when you first start it up when it's cold too.

Any ideas? :confused:
 

·
Premium Member
Joined
·
3,231 Posts
it spits did you do the Barry Mod? If so the spitting as you call it is due to the MAF on the wrong angle. Could be a few degrees and itll do that.
 

·
Registered
Joined
·
786 Posts
Discussion Starter #3
No Barry mod, just remove the airbox.
 

·
Premium Member
Joined
·
3,231 Posts
most likely your problem. What kind of filter are you running?
 

·
Registered
Joined
·
786 Posts
Discussion Starter #5
APC until I get Adam's intake. I think it was the same before the airbox removal though.
 

·
Registered
Joined
·
3,140 Posts
loumoll said:
I'm going to the dealer again for the second time, no brake lights! It sucks almost getting rear-ended. Also there's hesitation on the highway every 10 seconds or so. It spits, if you know what I mean. Runs like shit when you first start it up when it's cold too.

Any ideas? :confused:
was it only your brake lights? any dash lights go off?
 

·
Registered
Joined
·
786 Posts
Discussion Starter #7
No dash lights. But the worst thing is when the brake lights blow a fuse, the cruise won't shut off when you tap the brakes!!!! :eek:
 

·
Registered
Joined
·
683 Posts
loumoll said:
No dash lights. But the worst thing is when the brake lights blow a fuse, the cruise won't shut off when you tap the brakes!!!! :eek:
loumoll said:
That is NUTS, man would freak me out, same thing happened to me in my 81 vette, but actually the carb got stuck open, I poo'd myself, i was 16. :)
 
1 - 8 of 8 Posts
Top