Saturn ION RedLine Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
674 Posts
Discussion Starter #1
Well, I pulled that RL out tonight to let it warm up before school and whamo!, another puddle of oil under the car. Doing some looking it is the same problem that I had the car in for 100 miles ago. The cam position sensor housing gasket is leaking again. Well.......I'm begining to get perturbed. :mad:

They are supposed to look at it tommorow. They did offer to replace the car but do not have any RL's left with all of the options or the same color that mine has. I am not sure what to do. They also had mentioned the posibility of an extended warranty for the car but can't decide if they want to do that or not.

I don't know what to do with my car to be honest. I love the car so far but if this is going to be a recuring theme I am going to ask for my old car back and start all over. :(

Kind of dissapointed :(
 

·
Registered
Joined
·
3,574 Posts
Well, I was about to give up on my car and file a lemon suit because of a tranny leak I had for like a month. Finally, 8 or 9 visits later and 3 rentals, they decided to give me a new tranny. No leaks since and I am back to loving my car.

Hell, at least they are offering to get you a new car. My dealer wouldn't even do that and I fought with them for a new tranny until they finally folded and got one for it.
 

·
Registered
Joined
·
5,202 Posts
Look at the bright side, they are accepting responsibility for the problem and trying to take care of the situtation in the best way. If they don't have the same RL, ask if they can get you one from another dealership. I guarantee they cn ship one in from somewhere. At the very least, a free extended warranty really helps out after 36,000 miles. Trust me, if they are offering these things to you they really want you to be completly happy with your RL. All you have to do is tell them what you want and what would make you happy in this situtation. If you want a new car, ask for them to get you one. You have nothing to lose, right?
 

·
Registered
Joined
·
258 Posts
Hey if they don't have one you want, tell 'em you will be happy to wait for an '05 with the comp pkg! :D
 

·
Registered
Joined
·
351 Posts
Leaking parts here to

Hey I have had the same problem accept mine started with the not starting problem. Then progress to the oil leaking from the cam sensor. It went from Not starting to starting with oil leak back to not starting and no oil leak for 3 cam sensors, 3 seal replacements and 3 rental cars. Oh and I got 6 free oil changes out of it. Its a cracked cam sensor O-ring that was the problem on mine. Well now I have no Oil leak, but now it start most of the time. I have found a trick to it thou. I found if you try and start and it does not start to turn the key to the ACC postion and not the off postion. Then restart it and it starts right up every time. There is a new ECU reprograming coming out in the middle of Feb. To fix this start up problem.
 
1 - 5 of 5 Posts
Top