Saturn ION RedLine Forums banner
1 - 20 of 25 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
Im new to the redlines, and i know this code follows to every car out there, but this one is just blowing my mind. Car drives fine over 3000rpm but when its under 3k it misses really bad and struggles to accelerate. ive tried many things to fix and it still continues, im lost.
 

·
Super Moderator
Joined
·
1,643 Posts
Have you gone over the coil harness? Checked the ground wires?

Sorry. Didnt mean to sound so blunt in my first post.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #5 ·
No problem, its all good, and yes i checked the harness and everything seemed to be ok from what i could tell, i also checked the coils but they all also seemed to be in working order, previous owner said timing was done so im hoping it wasnt put into time wrong.
 

·
Super Moderator
Joined
·
1,643 Posts
Timing usually throws a cam or crank code.
Did you double check plug gap?
 

·
Super Moderator
Joined
·
1,643 Posts
You're using premium fuel yea?
 

·
Super Moderator
Joined
·
1,643 Posts
Confirmed fuel pressure at the rail and all injectors firing?
 

·
Super Moderator
Joined
·
1,643 Posts
Last thing I can think of is the fuel injectors being clogged/not spraying correctly. Or maybe a tank of bad gas?
I'm at a loss.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #13 ·
Last thing I can think of is the fuel injectors being clogged/not spraying correctly. Or maybe a tank of bad gas?
I'm at a loss.
I was suspecting that as well cause everything electrical or spark seems ok, the car was sitting for a little bit before bought so maybe bad gas or just bad injectors, who knows ill just have to pull em both
 

·
Registered
Joined
·
764 Posts
If the timing chain chain was done I would look at the timing chain tensioner.. might be not working properly or incorrectly installed or aligned.. At idle open the hood of the car and is there anything that doesn't sound right..? my tensioner went and it sounded like marbles bouncing around inside my engine..make sure to check for corrosion on the ground cables to the chasis of the car.. there are 5 of them I think... you might be looking at a tuning issue or a PCM going bad
 

·
Premium Member
Joined
·
2,205 Posts
Mine was sitting for a while when I got it in 2014

I had a lot of hestation experiences while accelerating at first

- I also had a bad CAT -

just the shift with the power, perhaps, and the way this transmission

is set, makes it an unusual acceleration experience.

wow there are alot reasons for these problems

did you change that air filter?

I had a significant upgrade when I got a new one in there.


I takes a long time to get these cars running optimally
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #16 ·
If the timing chain chain was done I would look at the timing chain tensioner.. might be not working properly or incorrectly installed or aligned.. At idle open the hood of the car and is there anything that doesn't sound right..? my tensioner went and it sounded like marbles bouncing around inside my engine..make sure to check for corrosion on the ground cables to the chasis of the car.. there are 5 of them I think... you might be looking at a tuning issue or a PCM going bad
I was stumped completely so i took it to a shop that works on cars like these, and he said it has a history of a throttle body code, and was 80% sure a new TB might fix it but not for certain.
 

·
Premium Member
Joined
·
2,205 Posts
good point ... what other codes are you getting?
 

·
Premium Member
Joined
·
2,205 Posts
Im only getting the p0300 and another code i forget, but its nothing serious at all besides the p0300

you probably did this but ... and that code is very unusual for the common codes that we get.

p1182 - supercharger code is the one that I used to get often

some recommendations:

clean the throttle body really good - take your time and get all the corners and cracks.

Replace the supercharger inlet gasket that connects between the air intake and supercharger inlet

clean the connected hoses and make sure everything has a good seal - air intake hose is functioning "vacuum seal" if stock

Clean the MAF sensor

Replace air filter and clean the tubing and any parts if you have the stock container

check the emissions hoses and make sure all sealed and cleaned up - no cracks

I hope it is not an engine issue but these maintenance items are really important

how's your exhaust?

I know there is a technical way to clean the injectors which perhaps you can do as you stated

saw this on an auto show and it was pretty cool -the standard injector service
I have gotten in the past is probably a tech opening a container down the gas tank and I paying big bucks for that - this is frustrating that they charge $150-200 for the injector service and they just empty a can of product.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #20 ·
you probably did this but ... and that code is very unusual for the common codes that we get.

p1182 - supercharger code is the one that I used to get often

some recommendations:

clean the throttle body really good - take your time and get all the corners and cracks.

Replace the supercharger inlet gasket that connects between the air intake and TB

clean the connected hoses and make sure everything has a good seal - air intake hose is functioning "vacuum seal" if stock

Clean the MAF sensor

Replace air filter and clean the tubing and any parts if you have the stock container

check the emissions hoses and make sure all sealed and cleaned up - no cracks

I hope it is not an engine issue but these maintenance items are really important

how's your exhaust?

I know there is a technical way to clean the injectors which perhaps you can do as you stated

saw this on an auto show and it was pretty cool -the standard injector service
I have gotten in the past is probably a tech opening a container down the gas tank and I paying big bucks for that
Exhaust is stock, still has cat. And i according the the guy working on it at this point, its in reduced engine power, speculating that a new throttle body will fix the problem, he also checked for any vaccum leak and could not find anything, and he also said that fuel trims were a little high, but nothing too crazy. So hes putting a new throttle body on at this point to help fix the issue.
 
1 - 20 of 25 Posts
Top