Saturn ION RedLine Forums banner

21 - 31 of 31 Posts

·
Registered
Joined
·
1,100 Posts
Discussion Starter #21
Just an update. Took the car to the alignment shop today and got the news. Alignment was way out of spec. Front driver toe was at -0.19 and passenger was at -1.38. Passenger side front camber was also at nearly 2° while driver was at around 1°. I don't know why the car was so far out but it's now corrected. They had to enlarge the lower strut bolt in order to adjust the camber on the passenger side but said that everything is now true.

Hopefully this alignment will hold for a while and I'll get some mileage out of this set of tires. In either case it has felt good to be back in the RL for the last couple of days. Been driving a diesel F-250 for the last year and a half and the dynamics of this little car are just so much different. It almost makes me want to go tackle some twisties :) For the sake of my tires and front end I won't though. Now if somebody could help me get my cruise control working again we'll be 100% back in business...........Thanks again for the help guys.
 

·
Registered
Joined
·
9,397 Posts
if your cruise is not working, try starting your car in neutral without pressing the clutch. your clutch switch may be bad.
 

·
Registered
Joined
·
1,100 Posts
Discussion Starter #23
if your cruise is not working, try starting your car in neutral without pressing the clutch. your clutch switch may be bad.
Thanks, I've tried that actually. I've also adjusted the cruise switch to no avail. It's gone out and come back several times since I bought the car back in 05. The dealer never could get it on consistently. It finally went last year and never came back. Took it in for warranty work again but was denied warranty as Saturn said that I had two dates listed for warranty expiration......of course they chose the earliest of the two. I'm gonna try to unhook the battery and let the computer reset then give it another go. After that I'm clean out of ideas. As a side note, the dealership did nothing but adjust the clutch switch the couple of times I took it in for this problem and it worked.
 

·
Registered
Joined
·
1,100 Posts
Discussion Starter #25
brake switch maybe?
Hmmm, perhaps. Do you know where the brake switch is located. I don't recall seeing it when I adjusted the clutch switch. Is it in the engine bay or in the cabin?
 

·
Registered
Joined
·
9,397 Posts
i assume it's inside near the top of the brake pedal arm. that's where it is on all the german cars i work on.
 

·
Registered
Joined
·
436 Posts
wow

yeah my cruise control hasnt worked since i got the car !! lol i think it is a relay . ,my back tires look just like that and i have a bent crossmember so yeah u for sure had alingment issue . glad to see u got it fixed lol:)
 

·
Registered
Joined
·
1,100 Posts
Discussion Starter #28
yeah my cruise control hasnt worked since i got the car !! lol i think it is a relay . ,my back tires look just like that and i have a bent crossmember so yeah u for sure had alingment issue . glad to see u got it fixed lol:)
Thanks, keeping my fingers crossed on the tire wear issue. As far as the cruise control............well interestingly enough, after unplugging the battery for about 15 minutes today it seems to be working again. I'm wondering if after adjusting the clutch switch the computer just needed to be reset. In either case it seems that my little RL is coming along. It probably won't work for everyone as it can be caused by a variety of issues but if your cruise is out it doesn't hurt to try to disconnect your negative terminal for a few minutes and see what happens.
 

·
Registered
Joined
·
1,885 Posts
Inner edge wear on Ion's is actually somewhat normal. There was even a TSB on it to adjust the toe inward to correct it as some came near the max toe out specs from the factory.

As far as the cruise goes. I've seen more than a fair share of randomly inop cruise systems and almost every single one was due to the cruise brake switch to stoplamp switch correlation. You need a scantool to monitor the switches to properly adjust them to as close to switch release position as possible. What you did with disconnecting the battery was just clearing the fault detected by the computer that disables the cruise. It will likely come back again.
 

·
Registered
Joined
·
1,573 Posts
Cruise control inop

My dealer actually knew something for once when i asked them about the cruise inop. What they said was if the following occur.

Cruise Switch on
Brake is pressed (any range)
Clutch is pressed (not full in or full out)

If this combination is reached 5 times it throws a code to the ECU and kills the cruise.

It doesn't make a whole lot of sense because if you're coming off the highway and pulling into a gas station the likliness of this occuring is high. Also if you encounter traffic after being on cruise. The dealer agreed it was dumb but couldn't do anything about it. from my playing with it, it seems like accurate information.

To fix it, clear the codes from the ECU. You can do so by either having a code reader, hp tuners, or disconnect the battery for 5-10 mins.

Hope that helps.
 

·
Registered
Joined
·
2,967 Posts
My dealer actually knew something for once when i asked them about the cruise inop. What they said was if the following occur.

Cruise Switch on
Brake is pressed (any range)
Clutch is pressed (not full in or full out)

If this combination is reached 5 times it throws a code to the ECU and kills the cruise.

It doesn't make a whole lot of sense because if you're coming off the highway and pulling into a gas station the likliness of this occuring is high. Also if you encounter traffic after being on cruise. The dealer agreed it was dumb but couldn't do anything about it. from my playing with it, it seems like accurate information.

To fix it, clear the codes from the ECU. You can do so by either having a code reader, hp tuners, or disconnect the battery for 5-10 mins.

Hope that helps.
Absolutely not true. I have my cruise button on all the time. Never shut it off except by accident. I hit my brake and clutch many more times than that everyday going to work without actually using (setting) the cruise. It works just fine when I hit the highway and can use it.
 
21 - 31 of 31 Posts
Top