Saturn ION RedLine Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
294 Posts
Discussion Starter #1
Hey guys, wondering of anyone has any idea why I am getting a random 'Coolant' message in the info window.

It pops up i check my temps with OBD and torque app, sitting pretty at 180°f, IAT2 sitting at 106°f

A couple minutes later, it goes off. This has happened 5 or 6 times now. I'll check coolant levels and nothing has changed, still right on the money, both engine and option B levels.

Just curious if anyone else has seems this?
 

·
Registered
Joined
·
294 Posts
Discussion Starter #3
Checked both hot and cold, dead on the line cold.

It did it again today, seems like once per drive. Stays on for about 15 to 20 secs then goes off.

Do you know which sensor and where the culprate is likely to be?
 

·
Registered
Joined
·
933 Posts
Checked both hot and cold, dead on the line cold.

It did it again today, seems like once per drive. Stays on for about 15 to 20 secs then goes off.

Do you know which sensor and where the culprate is likely to be?
Coolant level sensor, in the coolant tank.
 

·
Registered
Joined
·
294 Posts
Discussion Starter #5
Thanks Rebel, I'll check it out see if I can clean or replace it
 

·
Registered
Joined
·
294 Posts
Discussion Starter #6
So the auto parts store says I need to replace the whole coolant reservoir in order to replace the level sensor.

Is this truth?

I took a reservoir out of another ion at the scrap yard to make an option B kit, maybe I'll try switching them? Though I dont remember there being a wire harness on that reservoir.
 

·
Registered
Joined
·
2 Posts
That is the truth unfortunately, sensor is embedded in the reservoir. Nice outside the box thinking with the home brew Opt.B, I might follow those same steps. BTW mine has the coolant sensor thats goobered too, just not that concerned about it haha
 

·
Registered
Joined
·
294 Posts
Discussion Starter #8
Yeah i probably had $25 in my option B, I used some of the hoses off the same car at the scrap yard. Worst part was trying to find a right angle fitting for the top of the intercooler. Ended up ordering one.

I think I'll wait for summer and try switching them out. The dinging isnt too annoying yet.
 

·
Registered
Joined
·
2,100 Posts
Yeah i probably had $25 in my option B, I used some of the hoses off the same car at the scrap yard. Worst part was trying to find a right angle fitting for the top of the intercooler. Ended up ordering one.

I think I'll wait for summer and try switching them out. The dinging isnt too annoying yet.


Just curious what coolant are you using?
 
1 - 11 of 11 Posts
Top