Saturn ION RedLine Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter · #1 ·
My car randomly goes into limp mode after about 15 mins of driving and shoots these codes
P0651
P2138
P2135

They are Accelerator Pedal Position sensor, Throttle position sensor, and 5v Circuit fail.

Any ideas?
 

·
Super Moderator
Joined
·
1,810 Posts
There is a bundle of wires on top of the trans that is prone to chaffing some wires and grounding out. I chased a similar issue for months. Code bouncing between the TB and ACC pedal. Replaced both with GM parts.
Until one night a buddy and I were doing some other work, and that bundle got moved, then the codes werent there and the car wasnt limping a couple key cycles later. We traced it back to a couple of wires being messed up. Dont remember the colors, but at least a starting point.
With a circuit code being in there I would start with checking the wiring.
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #3 ·
There is a bundle of wires on top of the trans that is prone to chaffing some wires and grounding out. I chased a similar issue for months. Code bouncing between the TB and ACC pedal. Replaced both with GM parts.
Until one night a buddy and I were doing some other work, and that bundle got moved, then the codes werent there and the car wasnt limping a couple key cycles later. We traced it back to a couple of wires being messed up. Dont remember the colors, but at least a starting point.
With a circuit code being in there I would start with checking the wiring.
I looked and don't see any rubbed through wires, and last night I only got the Throttle Body code. There was only one wiring harness that looked like it could be an issue so I just relocated it.
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #4 ·
Replaced the throttle body, ECM, and Accel Pedal. Still getting theses codes but only after about 20 mins of driving, it happens everytime I drive and always around 20 mins
 

·
Super Moderator
Joined
·
1,810 Posts
Have you tested for power and ground at each connector?
 
1 - 6 of 6 Posts
Top