Saturn ION RedLine Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
258 Posts
Discussion Starter #1
Well, with 200 miles on her, my RL was towed into dealer today. Driving along when two warning lites come on and engine begins puking like its trying to run on 3 cylinders. One was the eng warning lite, the other was next to the tach and looks like the eng lite but with a "down arrow" in it. The service writer said it was a low coolant lite, which I know its not! Error code said problem with throttle positioning sensor. Anyway, I'm in a rental for now. Anybody has this happen or know what that lite is for? Thanks!
 

·
Registered
Joined
·
37 Posts
yup thats the coolant light. you were running low. probably spun a rod or something cuz temps got hella hot.
 

·
Registered
Joined
·
258 Posts
Discussion Starter #3
Back from dealer today. Replaced throttle body unit, which cleared error code. Still couldn't get a straight answer about that warning lite next to the tach, since coolant level was fine and coolant temp never went past 1/2 on guage. Strange that there is nothing in the manual about it.
 

·
Registered
Joined
·
5,202 Posts
That is your reduced power light. Strange that it is not in the owners manual though. The dealership did not tell you what that light was, though?
 

·
Registered
Joined
·
258 Posts
Discussion Starter #5
NO! They said it was a low coolant light. Under what conditions should that light come on? Thanks!
 

·
Registered
Joined
·
114 Posts
that same shit happened to me a while ago. I let it sit for ten minutes and it drove fine and the lights turned off. I took it in to the shop anyway but thhey couldnt find anyhting wrong. But a code for the throttle body did come up along with one for the electrical systems. It hasnt happened again and that was almost 1000 miles ago.
 

·
Registered
Joined
·
258 Posts
Discussion Starter #7
Back in the shop AGAIN!!! Now they know what that idiot lite is for; when the engine goes into limp dick mode so you can safely get it to repair. Now they need to figure out why it is doing it!!
 

·
Registered
Joined
·
5,202 Posts
It's not really common for that light to come on on RL's --- of course, they are brand new. I have seen that light come on with throttle body issues in the L-Series, but not Ions. I tend to not use the "limp dick mode" description, but it's really fitting. Let us know what the dealership does to fix the problem. I am a little curious.
 

·
Registered
Joined
·
258 Posts
Discussion Starter #9
Pardon my sarcasm, but given the performance of my RL in "Limp mode", the analogy seemed appropriate!!! Anyway, Saturn is overnighting an ECU to my dealer. They think that will fix the problem. We shall see... I'll let you all know.
 

·
Registered
Joined
·
258 Posts
Discussion Starter #10
New ECU in. They programmed with latest updates too. We'll see if this cures the problem!
 
1 - 10 of 10 Posts
Top