Saturn ION RedLine Forums banner
101 - 120 of 122 Posts

·
Registered
2004 Saturn Ion Redline
Joined
·
99 Posts
Discussion Starter · #101 ·
Success!!

The journey has been long but the car is running and driving again. The clutch feels like new!!

I have an actual reservoir coming but I did rig something up to get by for now and honestly I don't see why it wouldn't last. The guy at Autozone was an idiot and had no idea about the nylon hose or crimps.. I grabbed some high pressure fuel hose and some hose clamps

The system is holding pressure and I was able to bleed the clutch. Night and day difference with that pedal


I still need an alignment and install the new reservoir once it comes but she went for a drive today!! 😍😁
 

Attachments

·
Registered
2004 Saturn Ion Redline
Joined
·
99 Posts
Discussion Starter · #102 ·
First drive and I couldn't help myself.....lol 🤣🤣

 

·
Super Moderator
Joined
·
1,810 Posts
Hm. Maybe I should grab em when I see them at the junk yard then. Along with clutch pipes.
5 speed Ions are getting hard to find at yard period. Could probably add that to my list of parts to make.
I know for sure there is 1 5 speed at my local yard now.

Yeaaaa man!!! Hows that sense of accomplishment feel???
I know its been a frustrating journey, but super excited to see the ole girl moving again!
 

·
Registered
2004 Saturn Ion Redline
Joined
·
99 Posts
Discussion Starter · #104 ·
Hm. Maybe I should grab em when I see them at the junk yard then. Along with clutch pipes.
5 speed Ions are getting hard to find at yard period. Could probably add that to my list of parts to make.
I know for sure there is 1 5 speed at my local yard now.

Yeaaaa man!!! Hows that sense of accomplishment feel???
I know its been a frustrating journey, but super excited to see the ole girl moving again!
It feels great man! I love it when I can maintain my own vehicles

I did move some things around between the 2 Redlines.
I wasn't really digging the Drift Alloy wheels on Red so I switched them with Pearl. Also borrowed her mesh grille and have another on order. I wish I could get the Comp wheels refinished so I can use them but with everything it took to fix Reds clutch it's out of budget. For now, I'm happy with how she looks with these.

I like how Pearl is looking too

Red's going for her alignment tomorrow and I plan to start DD her. We'll see how that goes. Sometimes I get a banging noise I believe is from the passenger axle. I'll check out tonight when it cools off
 

Attachments

·
Super Moderator
Joined
·
1,810 Posts
Clutch going out on my 03 is what got me wrenching. That 1700 shop bill being 17 almost 18 years old wasn't gonna work for me.

You'll save a bunch of money doing your own work.

As far as the wheels go. Watch some YouTube videos. I'm sure you can do it on your own with some patience once funds allow. It'll be way cheaper than a shop doing them. Planning to learn once I get an engine back in the car.

Jack it back up and re check that everything tight. Start grabbing things and yanking to see where the play is. That's all we do at the shop. Plus check for wear. But you replaced everything already
 

·
Registered
2004 Saturn Ion Redline
Joined
·
99 Posts
Discussion Starter · #106 ·
Clutch going out on my 03 is what got me wrenching. That 1700 shop bill being 17 almost 18 years old wasn't gonna work for me.

You'll save a bunch of money doing your own work.

As far as the wheels go. Watch some YouTube videos. I'm sure you can do it on your own with some patience once funds allow. It'll be way cheaper than a shop doing them. Planning to learn once I get an engine back in the car.

Jack it back up and re check that everything tight. Start grabbing things and yanking to see where the play is. That's all we do at the shop. Plus check for wear. But you replaced everything already
Got it. I'll report back what I find
 

·
Registered
2004 Saturn Ion Redline
Joined
·
99 Posts
Discussion Starter · #107 ·
Update: 7/11

Well I have good news and bad news!

Good news is I checked the suspension, everything is tight but I haven't heard any noises.

Bad news is the reek of fuel problem culprit was discovered while she was in for alignment. And it's the worst scenario.

The spot these cars are known for is rusted causing the leak. With the vapor line right next to it, and my "check gas cap" message a few weeks back pretty much cements the fact I'm gonna be replacing the fuel lines and vapor lines.

I've never done fuel lines before, but if I was able to do the clutch I should be able to handle this right?

I'm not looking forward to it but it's gotta be done. I'll probably spend a couple days researching it
 

Attachments

·
Super Moderator
Joined
·
1,810 Posts
Fuel lines should be a cake walk for yuh after doing a clutch.
Replace your fuel filter while you're at it. They're like $20ish.
And when you order a fuel line disconnect tool, make sure it's metal and not plastic.
 

·
Registered
2004 Saturn Ion Redline
Joined
·
99 Posts
Discussion Starter · #109 ·
Update: 7/12

I got all the lines out!! Brake lines are cruddy from the gas dripping on them and dirt/grime stuck to them. Cleaned them off and they look great.

Turned out I was right, while the purge line wasn't as bad as the feed line, it was also very rusty and leaking. Those stupid heat foils!!! 🖕

I have the zzp AN fuel feed kit on the way and today I ordered what I thought was a complete front to back nylon fuel line kit but I'm told they only reach the driver door and your supposed to use the metal line up into the engine. The guy on the FB group told me to just use the whole kit for the evap line since I already have the zzp one coming, and they are both 3/8

We'll see when everything gets here. I'm hoping to have her buttoned up and tearing the roads up again this weekend
 

Attachments

·
Super Moderator
Joined
·
1,810 Posts
Sweet! See, it wasnt that bad!!
Takes some time. And a very known issue with the platform as a whole.

Luckily my 03 wasnt up north long enough. And my Redline is from Cali.

Now we just need to get you running some amsoil through your fleet ;)
 

·
Registered
2004 Saturn Ion Redline
Joined
·
99 Posts
Discussion Starter · #111 ·
Update: 7/13

I got the new braided fuel feed line in and the car is running again

However my first drive wasn't very fun! I started getting a misfire and the CEL was flashing but went out eventually. I still had a code p0300 not cylinder specific misfire, the engine evened out and I continued. Then for the 2nd time I got "check gas cap" message. I thought the evap must still have a leak 🤷‍♂️

When I returned home I checked the cap again the cap was not secured down...

I tightened it down and I'll see how my drive goes tomorrow, but I'm wondering is there something in these cars that will cause the gas cap to blow off? The CEL is off and I checked for codes after the p0300 and I got no stored codes

Should I replace the cap? I have to address the cap issue before I can determine if the evap system is sealed
 

Attachments

·
Super Moderator
Joined
·
1,810 Posts
Ive seen a handful of instances where the filler neck had a small crack causing an evap leak.
Can also check to see if the vent tube is clogged
 

·
Registered
2004 Saturn Ion Redline
Joined
·
99 Posts
Discussion Starter · #113 ·
Ive seen a handful of instances where the filler neck had a small crack causing an evap leak.
Can also check to see if the vent tube is clogged
Update: 7/15

The car has been running and driving beautifully!! I did check the suspension and tightened down the driver side LCA and I'm able to tighten down the gas cap and haven't seen the "gas cap" message since

I'll continue to update as I drive the car. I'm enjoying her and feel very accomplished

Just got back from the carwash. Cleaned a month of bird crap and pollen off her
 

Attachments

·
Super Moderator
Joined
·
1,810 Posts
So glad its running, and running good!!
I think break in period for the clutch is like 500miles. So not to hard, but dont baby it.

Go for a cruise and crack a cold you my dude!
 

·
Registered
2004 Saturn Ion Redline
Joined
·
99 Posts
Discussion Starter · #115 ·
So glad its running, and running good!!
I think break in period for the clutch is like 500miles. So not to hard, but dont baby it.

Go for a cruise and crack a cold you my dude!
I have noticed a difference between my 2005 and my Comp car, the 05 feels quicker but it might be because I'm trying to take it easier on her for now

Both cars are built about the same except the 05 has a stage 2 6 puck clutch, long tube headers, and ported/polished blower

The Comp has GMPP clutch, and 2.5 exhaust
 

·
Super Moderator
Joined
·
1,810 Posts
That 6 puck probably bites a lot harder.
Could all be in your mind.

Bring em down to texas and ill check for yuh lmao
 

·
Registered
2004 Saturn Ion Redline
Joined
·
99 Posts
Discussion Starter · #117 ·
That 6 puck probably bites a lot harder.
Could all be in your mind.

Bring em down to texas and ill check for yuh lmao
Lol I do have some family down there, Wylie TX. Road trip 🤣🤣

Update: 7/16

Seems my 2005 Redline got jealous of all the attention the Comp car was getting. Think I might be losing my fuel pump. Drove her for a little bit today and every time she has not done her normal start up. She's cranking longer than normal, and she doesn't sound healthy when she fires, just kinda blurp blurps to idle (hard to explain). I'm barely hearing the fuel pump prime with the key on too, 🤷‍♂️. The clutch pedal is engaging almost to the floor

I still have the 2006 clutch pedal and a brand new bushing. I think I'll put them in the 2005 to get the clutch working better.

I'll check my fuel pressure tomorrow and do a leak down to see if the fuel pump is going out.

I also curbed my brand new wheels on her and left some rash

Wasn't a good day for ole' Pearl though. I'll get her fixed though
 

Attachments

·
Super Moderator
Joined
·
1,810 Posts
Lol I do have some family down there, Wylie TX. Road trip 🤣🤣

Update: 7/16

Seems my 2005 Redline got jealous of all the attention the Comp car was getting. Think I might be losing my fuel pump. Drove her for a little bit today and every time she has not done her normal start up. She's cranking longer than normal, and she doesn't sound healthy when she fires, just kinda blurp blurps to idle (hard to explain). I'm barely hearing the fuel pump prime with the key on too, 🤷‍♂️. The clutch pedal is engaging almost to the floor

I still have the 2006 clutch pedal and a brand new bushing. I think I'll put them in the 2005 to get the clutch working better.

I'll check my fuel pressure tomorrow and do a leak down to see if the fuel pump is going out.

I also curbed my brand new wheels on her and left some rash

Wasn't a good day for ole' Pearl though. I'll get her fixed though
Wylie is less than 2 hours west from me.

You got it right on with the fuel pressure test. And good ear with the fuel pump prime.
At least you are familiar with where the fuel lines are and how to drop the tank now lmao

oof i feel the pain on that wheel. At least it isnt to bad. That can be fixed.
Ive see videos online of people repairing light rash like that fairly easily. I still want to try to do it myself one day
 

·
Registered
2004 Saturn Ion Redline
Joined
·
99 Posts
Discussion Starter · #119 ·
Wylie is less than 2 hours west from me.

You got it right on with the fuel pressure test. And good ear with the fuel pump prime.
At least you are familiar with where the fuel lines are and how to drop the tank now lmao

oof i feel the pain on that wheel. At least it isnt to bad. That can be fixed.
Ive see videos online of people repairing light rash like that fairly easily. I still want to try to do it myself one day
Update: 7/19

I finally got back out to the car, work has been nuts lately and the temps have been in the 90s, without a garage, it's not ideal conditions. I was able to test the fuel pressure and it was holding pretty good. KOEO read 60 at first, after 10 minutes was approaching 44. KOER the gauge read 60. My fuel pump might be good, however I had a CEL and 2 codes stored p0107 and p0833

P0107 is MAP sensor voltage below .2 for 6 seconds or more I believe

P0833 is clutch pedal switch circuit 🤷‍♂️

I don't believe these codes would be contributing to my poor start condition. I did a cold start today and the engine fired like normal so I think from here I'm gonna focus my attention on the clutch pedal. See if anything changes with the start condition after
 

Attachments

·
Super Moderator
Joined
·
1,810 Posts
codes are unrelated. make sure you the clutch pedal switch is plugged in all the way. And same with the map.
Being you had both areas taken apart, good idea to double check.
I hate electrical
 
101 - 120 of 122 Posts
Top