Saturn ION RedLine Forums banner

1 - 15 of 15 Posts

·
Registered
Joined
·
101 Posts
Discussion Starter #1
I think i got a defective one, after i installed it i started the car, was like normal.
but when i started driving something was funny, the car stays at like 1800 rpms with the clutch in or car in neutral doing like 3 mph and doesn't drop untill a couple of senconds after you completely stop. Thats not all after the car warmed up it started idiling really ruff like a missfire and its the jerkiest ride ever . If im in 1'st and shift into second the rpmsdrop really fast and when i shift the whole car starts bucking and sputtering, well its pretty bad. i have tried resetting the computer and still no good. i did get a cel the code number is p0507(the pcm has determined that the engine rpm is higher than expected for the current engine opperating conditions) ya gots me? sms is being cool about it , just wondering if any one has a quick fix idea.

just my luck when it comes to parts, always get the defective ones. So don't laugh when you go to bestbuy and see me taking everything off the shelf to get the one in back :)
 

·
Moderator Kitteh!
Joined
·
11,564 Posts
HiRevdLine said:
So don't laugh when you go to bestbuy and see me taking everything off the shelf to get the one in back :)
thats where they keep all the returns that dont work:D
 

·
Registered
Joined
·
2,813 Posts
Vacuum leaks
Excessive deposits in the throttle body
A faulty positive crankcase ventilation (PCV) valve
A skewed MAP sensor--Refer to

check those.... if it doesn't help anything then your screwed
 

·
Registered
Joined
·
1,170 Posts
both of my cars had a high idle issue but after awhile it went away like the ecu had to relearn the values.
 

·
Registered
Joined
·
851 Posts
Hmm, I was thinking of getting that big bore throttle body, but now I'm scared....:confused:
 

·
Registered
Joined
·
2,233 Posts
Others have used the SMS BB TB without issue. Either you damaged the seal somehow on the intake to TB mount (vacuum leak) OR there's something wrong with that TB (bent or off-center plate, motor close mechanism etc) With the IGN OFF the throttle plates should be spring-loaded to a slightly open position and you should be able to push on the plate with your finger to close it OR open it BUT it springs right back to slightly open
If it's messed I'm sure Wes will rectify the issue.
Wop
 

·
Registered
Joined
·
230 Posts
Unless the Throttle Body is made from a solid Billett piece,there is usually casting debris left over and most of the time you will have to sand out the T/B inlet to remove all of the extra metal casting nubs so the butterfly will seat properly.

Im not too familar yet with your throttle body setup(new to the RL engine world) but is the Throttle Position sensor right on your throttle body? If so, they are very easy to damage. If that was removed and put back on roughly, it could have been damaged.

To test a vacuum leak, take some spray start fluid and spray it around your throttle body. Make sure all of your intake tubes are connected though. Tight everything up and try it. If the engine revs up, you have a vacuume leak.
 

·
Registered
Joined
·
851 Posts
Is this thing even worth buying>?
 

·
Superd00d
Joined
·
22,040 Posts
mogs01gt said:
Unless the Throttle Body is made from a solid Billett piece,there is usually casting debris left over and most of the time you will have to sand out the T/B inlet to remove all of the extra metal casting nubs so the butterfly will seat properly.

Im not too familar yet with your throttle body setup(new to the RL engine world) but is the Throttle Position sensor right on your throttle body? If so, they are very easy to damage. If that was removed and put back on roughly, it could have been damaged.

To test a vacuum leak, take some spray start fluid and spray it around your throttle body. Make sure all of your intake tubes are connected though. Tight everything up and try it. If the engine revs up, you have a vacuume leak.
It's an original TB, that's be honed out, so casting debris shouldn't be an issue.

Not many people are familar with our odd, DBW throttle, but yes, there is a TPS on the TB, as far as I know.
 

·
Registered
Joined
·
1,170 Posts
I can say I am glad I got mine for both cars and they do make a difference but just not what some people may be expecting. By this I mean better throttle response, and will achive bigger gains after other mods. The cost is a little under 200 after the core. Why is yours messing up, I dont know but I can garentee that Wes will take care of it if given the chance.
 

·
Registered
Joined
·
101 Posts
Discussion Starter #14
Sinister redlines said:
I can say I am glad I got mine for both cars and they do make a difference but just not what some people may be expecting. By this I mean better throttle response, and will achive bigger gains after other mods. The cost is a little under 200 after the core. Why is yours messing up, I dont know but I can garentee that Wes will take care of it if given the chance.
wes is super cool about all this i put the stock one back on and car ran just fine :) so he told me to ship it on back and they send me a new one asap! very very very excellent customer service!
 

·
Registered
Joined
·
23 Posts
We have found a few factory t/b's to be defective. I am sure it is not the work done to them that was the problem, it has been the motor inside that has been an issue. Feel free to give me a call and we will ship another one out to you.

619-937-0478
 
1 - 15 of 15 Posts
Top