Saturn ION RedLine Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
I took my '04 Ion RL to Autozone to run a diagnostic test and it referenced a code that was in regards to the "supercharger inlet pressure sensor." Has anyone had any trouble with this? Think I should just go buy the sensor or could it be something else? The sensor runs about $80-100 from what I've located....
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #4 ·
SORRY it took me so long to respond!! Yes, it's the same code as listed above. I will try what was suggested this weekend. I was also given code P0341 "Cam Sensor Condition"

I will try to replace the spark plugs this weekend too and see if she starts running better. She has no go when switching gears. It's so frustrating!
 

·
Registered
Joined
·
7,305 Posts
yea probably, the only other nearby sensors are in the intake manifold and throttle body so since there is only one sensor on the SC (on top, in plain view) I'd bet it's that one. you could always unplug it to see if nothing changes and you still have your problem.
 

·
Registered
Joined
·
1 Posts
SORRY it took me so long to respond!! Yes, it's the same code as listed above. I will try what was suggested this weekend. I was also given code P0341 "Cam Sensor Condition"

I will try to replace the spark plugs this weekend too and see if she starts running better. She has no go when switching gears. It's so frustrating!

meow im super late to this party! So when you reference no power when switching gears. That’s what mine does and stalls super easy like going after sitting at a red light! No power at all but will gradually build power but the engine gurgles. And engine light flashes and Then code for IDLE AIR CONTROL VALVE. Which is confusing to me because I’ve replaced the TB 3 times because I’m pretty the IAC is intergrated into the TB. so I don’t know how to fix that other than pull over scan anderase codes and fires right back up!
 
1 - 7 of 7 Posts
Top