Saturn ION RedLine Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
1,191 Posts
Discussion Starter #1
After having my intake installed, I now have this problem every once in a while: At times while driving, when I give the car full throttle, it feels like a cylinder is shut off or something. The car is just flat. I can hear the sc whining, but my acceleration feels like that of a geo. Like I said, it only occurs once in a while, but I have no idea what's going on. Any ideas??? Anything I should do?
 

·
Registered
Joined
·
89 Posts
sounds like the limp mode everyone is talking about, i dont know much about it but geos are pretty limp compared to the redline....
 

·
Registered
Joined
·
4,148 Posts
have you tried checking the filter and clamp that holds the filter on. Sounds like you possibly might not have it on securely. That would be the first thing I would check.
 

·
Registered
Joined
·
103 Posts
If there's no warning light, then it hasn't entered limp-mode.

Stumbling on acceleration is usually either ignition (poor spark) or fuel delivery related. If this has only started happening since you installed the intake, though, then it could be a vac leak somewhere or the MAF sensor positioned wrong/badly and giving bad readings. I'd just pop the hood and give the intake a good look over. Make sure everything's on solid. Listen for vac leaks with the car running.
 

·
Registered
Joined
·
786 Posts
Your slipping the clutch, it happens to me once in a while when I really hop on it.
 

·
Registered
Joined
·
103 Posts
redlin-er said:
Your slipping the clutch, it happens to me once in a while when I really hop on it.
Good call, definitely possible too. You'll have to be careful when you drive it and note exactly what's happening. A slipping clutch should be obvious.
 

·
Registered
Joined
·
21 Posts
My Car Starting Doing Something Similar. But I Was Not Driving It. I Raced It Up A Few Times To Hear The Supercharger, And When It Went To Idle Down, It Wouldn't Idle Fast Enough, So I Guess The Computer Started Shutting Down Cylinders. It Did Turn On A Service Code, But I Just Said That The Engine Was Idling Higher Than The Computer Wanted It To. I Am Thinking That It Has Nothing To Do With The Cai But With The New Program When It Was Updated. I Am Going To Check With Saturn And See What The Newest Update Is And If They Have Had Any Problems Similer.
 

·
Registered
Joined
·
103 Posts
DRJOHN said:
My Car Starting Doing Something Similar. But I Was Not Driving It. I Raced It Up A Few Times To Hear The Supercharger, And When It Went To Idle Down, It Wouldn't Idle Fast Enough, So I Guess The Computer Started Shutting Down Cylinders. It Did Turn On A Service Code, But I Just Said That The Engine Was Idling Higher Than The Computer Wanted It To. I Am Thinking That It Has Nothing To Do With The Cai But With The New Program When It Was Updated. I Am Going To Check With Saturn And See What The Newest Update Is And If They Have Had Any Problems Similer.
A high idle is easily caused by a vacuum leak. And if you recently installed an intake, this is all the more likely. Check for vac leaks.

And easy on the shift key. :D
 
1 - 9 of 9 Posts
Top